BCBToolkit Questions

Hi,

can I send the log file to an e-mail address? I cannot upload files as new member.

Kind regards,
Selma

1 Like

Hi Chris and Michel.

Thank you for tour help. Premise: i am completely new to this field.

I recently installed your BCBtoolkit on my macbook pro running mac os big sur 11.1;

Here my problem: i’ve tried to use the Normalisation feature in order to use the diconnectome maps feature afterwards. The Normalisation process starts but it never ends, I waited more than an hour and at some point i decided to stop the process.

How long is this process usually? Is this normal? Have I done something wrong?

I can not attach the log file that was created during the process since I am a new user.

Thank you for your help!

Regards,

Aron

Hi Aron,

The process of normalisation is quite long actually in BCBtoolkit. Just let it run overnight :wink:
Cheers

Mich

Hi Mich,

thank you for your quick answer. I guess it’s gonna be a lot of nights then :sweat_smile:

Cheers.

Aron

You can run them all in a row in one night :wink:

Hi Chris and Michel,

unfortunately I have trouble using disconnectome mapping at all. I am working on a freshly installed Ubuntu 20.04.2 LTS virtual machine with the Linux version of BCB Toolkit downloaded today from the official website. When I start the GUI and run the disconnectome mapping with the example lesions shipped with the toolkit, a message occurs stating “Data properly written in /home/user/folder”. Unfortunately, this folder then only contains an empty subfolder ‘logs’. There is also no error message on the terminal from which BCB Toolkit was started. All folder names do not contain any special characters. Do you have any suggestion, how to further debug or even fix the issue?

Cheers

Max

Hi Max,

all apologies for the delay in our answer. For some reasons I did not receive an email informing me of your message. Would you have the kindness to share the log file with us so that we can see what was the bug thanks. mich

Hi Mich,

unfortunately, i can’t provide any logs because the folder ‘logs’ remains empty. There is also no error message on the terminal from which BCB Toolkit was started.

Cheers, Max

That is real weird I’ll have to call Chris on this because he knows linux better than me (I’m a Mac person sorry…). He should reply to you later today. meanwhile can you just check that there is no space sign in any of your directories. cheers mich

Hi Max,

It’s weird, I don’t remember having this error. The only things I can see from here are either a permission problem or an empty input directory (either your input directory or the BCBToolkit/Tools/extraFiles/tracks)
Have you tried with your own data?

Cheers,
Chris.

Hi Chris,

neither the input direcotry nor the tracks directory were empty. I also tried with my own data. I eventually got it to work using a coworkers Macbook …

Cheers, Max

Hi Chris and Michel

I’m working wiht BCBToolkit and have a few questions.

I try to perform a Kruskall-Wallis analysis with Bonferonni-Holm correction. I don’t understand the output files in my studies.
In fact, my Kruskal_pvalues.csv file shows that my 54 clusters have a pvalue < 0.05 and that the kw_holm is also < 0.05 that means all my clusters survived the BH correction.
However the last 3 columns (pval, stat and holm) show N/A and I don’t understand why. Does that mean the posthoc test failed ?

In previous works (in which I believed I have understood something :slight_smile: ) I thought that values of the voxel should correspond to the value in the csv file so we can filter voxel < 0.05 to identify significant voxel. (and one consequence was that if no voxel survived the BH correction, all the voxels of the file were at an intensity of 1 so there was a big white square). But my nifti files are curious (I open them in MRIcron or MRIcroGL) : indeed the kruskall_holm_clusters.nii.gz should indicate BH corrected pvalue after the KW test, and so all my voxel values should be < 0.05 but the map show voxel with 0.99 intensity level. It is the same for the kruskal_cluster.nii.gz where the value of the voxels do not correspond to the value in the csv file .But I had also curious results with voxels value at 0 but with clearly a white voxel on the screen corresponding to significant clusters and the voxel should have an intensity of 1…). Concerning the cluster.nii and cluster_holm.nii I don’t even know where to find the value…

Is it possible that the value of the voxel, if too low or with to many decimals could be misinterpreted by a software of visualization ?

Moreover I’m not sure to understand the difference between the nifti files very well when using the KW test with BH correction:

  • Does the clusters.nii file show the posthoc results for the clusters which passed the KW test ?
  • the kruskal_cluster.nii indicates pvalues ot the KW test before BH
  • the kruskal_holm_clusters indicates pvalue of the BH correction after KW
  • but what is the cluster_holm.nii when using KW and BH correction ? Does it show the significant cluster that passed the BH correction after KW test and the BH after post hoc test so the very end of the process ?

Sorry for this long question and thank you in advance.

Best regards

Fabien

Hi Fabien,

Sorry you’re having troubles with the toolkit :s.

So, the kruskal_pvalues.csv should contain the results of the tests. And if they have N/A yes, the tests went wrong. There should be another file called ‘test_warn.csv’ in case some warnings/errors were raised by the function performing the stats. You might have more info about what went wrong in there. You can send the messages or the file to me to have a look if it does not help.
The rest of the weird results is likely due to this error. The script tries to fill up the images but does not have the values so the images are broken.
In the nifti images, you should have 1 - pvalue or 1 - corrected_pvalue (apparently that’s a standard way to add the stats in an image). That’s why you can have .99, which is a significant cluster in that case.
Oh, and if there is Kruskal or kw in the name it refers to the kruskal wallis test only. Then cluster and cluster_holm are the posthoc stats between the two groups you selected (if they pass the kruskal wallis).

Hope it helps.
Best regards,
Chris.

Dear Chris and Michel,

I’m trying to run the Normalization tool but I’m getting the following error:
“Cannot open volume /home/edu_asus/Documentos/Grant/NIH/bcbtoolkit/Lesion/subj01AXT1.nii* for reading!”

I don’t know why it is looking for the file “subj01AXT1.nii” in the Lesion folder.
Running just with the T1 image it is ok. The problem is when I include the Lesion folder.
The lesion is in the the native space of the T1 image. I have also tried to change both images to the MNI space using:

flirt -interp nearestneighbour -in subj01lesion.nii.gz -ref $FSLDIR/data/standard/MNI152_T1_1mm_brain.nii.gz -out wsubj01lesion_lesion.nii -usesqform -applyxfm

flirt -interp nearestneighbour -in subj01AXT1.nii.gz -ref $FSLDIR/data/standard/MNI152_T1_1mm_brain.nii.gz -out wsubj01lesion_lesion.nii -usesqform -applyxfm

But I’ve got the same error. Please, how can I fix it?
I’m using Ubuntu 20.04. Follow attached my log file.

Sincerely,
Eduardo

logNormalisation.txt (3.0 KB)

Hi Eduardo,

This one is easy.
The lesion and the T1 image must have the exact same name for the normalisation to work.
We did that in order for users to be able to process several patients at the same time.
I should update our userguide!
Http://www.bcblab.com/BCB/Normalisation.html

Kind regards

Mich

Hi Dr Mich,

Sorry about that. Now I could see this information in the userguide:

" **exact same name as the T1 images used above "

Thank you!

My pleasure hope you will have fun with BCBtoolkit!

Hi Chris and Michel,

I’m attempting to use AnaCOM2 on the disconnectome images generated from the Disconnectome Map tool but got following message in terminal:
“Exception in thread “AWT-EventQueue-0” java.lang.ClassCastException: sun.awt.image.BufImgSurfaceData cannot be cast to sun.java2d.xr.XRSurfaceData”

It seems like the analysis is still running so I am unsure whether I should be concerned? For context, I am processing the data on a linux HPC desktop. I have 26 participants with disconnectome images and it has been running for about 2 days now.

Regards,
Abbie

Hi Abbie,

This is an exception thrown by the java GUI so, it will not affect the results of the analysis. I have seen some exceptions coming up when my screen turns off or things like that but the program is still running so it should be fine :).

Regards,
Chris

Dear Chris and Michel,

I am attempting to use the Disconnectome Maps feature of the BCBToolKit, using the additional Package X dataset (which I believe I have correctly added to the ToolKit’s folder). I am trying to calculate disconnectome maps using the ToolKit, and while this seems to have worked, it seems that some of the disconnectome map files I get as a result are empty (i.e., the BCBToolKit creates them, but there are just 0s in the nifti file).

To try to fix this, I have resliced some of my lesioned files to ensure that they were using the BCBToolKit MNI template (rather than the SPM one that I originally had, as per your advice in an earlier thread) in case this was the problem, but it does not seem to have helped. After having run some of these resliced nifti files through the ToolKit, I get nice looking disconnectome maps for some of my participants, but not all – for some of my participants, the resulting disconnectome map nifti file is still empty. Unfortunately, I’m not able to attach log files to illustrate as I’m a new user, but can do so by email if that helps!

Do you have any further ideas on what might be causing this? Also, while I know the ToolKit’s documentation states the lesioned nifti files should be binarised, not all of my lesioned nifti files are and some of these have still produced disconnectome maps. Is this possibly problematic?

Apologies for the lengthy description – I hope it’s not too confusing! Let me know if I can clarify my problem further. And thank you very much for developing the ToolKit and for having this forum for questions!!

Thanks very much,
Nadene