CPAC error in creating data_settings.yml template file

Dear experts,

Hi, I came here after facing consistent error in
creating data_settings.yml template file.

I am using a Big sur MacOS, already installed cpac & docker.

I tried the first command in the picture below to create data_settings file so that I can generate configuration file.
Screen Shot 2022-06-14 at 9.32.04 PM

However, I constantly get 'Read-only file system: ‘/logs’ error whenever I write this command in the terminal.
This is the code that I wrote.

hal@HALui-MacPro python3.10 % cpac pull
Loading 🐳 Docker
Pulling from fcpindi/c-pac
Digest: sha256:af7c4923989a9d042d24b293280db8079545ebde10fd91da6cca459a64160b0c
Status: Image is up to date for fcpindi/c-pac:latest
hal@HALui-MacPro python3.10 % cpac utils data_config new_settings_template

Loading 🐳 Docker
Traceback (most recent call last):
  File "/Library/Frameworks/Python.framework/Versions/3.10/bin/cpac", line 8, in <module>
  File "/Library/Frameworks/Python.framework/Versions/3.10/lib/python3.10/site-packages/cpac/", line 446, in run
  File "/Library/Frameworks/Python.framework/Versions/3.10/lib/python3.10/site-packages/cpac/", line 365, in main
  File "/Library/Frameworks/Python.framework/Versions/3.10/lib/python3.10/site-packages/cpac/backends/", line 24, in Backends
  File "/Library/Frameworks/Python.framework/Versions/3.10/lib/python3.10/site-packages/cpac/backends/", line 35, in __init__
  File "/Library/Frameworks/Python.framework/Versions/3.10/lib/python3.10/site-packages/cpac/backends/", line 78, in _collect_config
    kwargs = self.collect_config_bindings(self.config, **kwargs)
  File "/Library/Frameworks/Python.framework/Versions/3.10/lib/python3.10/site-packages/cpac/backends/", line 242, in collect_config_bindings
    os.makedirs(inner_binding, exist_ok=True)
  File "/Library/Frameworks/Python.framework/Versions/3.10/lib/python3.10/", line 225, in makedirs
    mkdir(name, mode)
OSError: [Errno 30] Read-only file system: '/logs'

I simply pulled to initiate cpac and tried to create data settings file.

I thought of several reasons for this

  1. need to change permission of ‘/logs’ file ?: After this error showed up, I tried to change mode into read-and-write of the /logs file, but failed because I couldn’t find the path and the directory to ‘/logs/’.

  2. perhaps pwd of the command was wrong?: Should I write the command in a different path? I tried this in a variety of directories where my data is, but failed.

I tried to do the docker version of creating data settings file (shown in the third command in the picture), but guess I misunderstood the ‘/path/to/data_config’ part. But after trying the docker command, I want to run a simpler first command if possible.

Does anyone have any idea on this problem?
I am a total novice in this field and any help would be so helpful!

Thanks a lot and have a nice day!


That looks to me like a known, unresolved issue running Docker on MacOS ≥ 12.0.1.

My best guess here is the same as this:

As in that thread, please let us know if you have success or figure out a workaround!

Ah, seems like I faced exactly the same problem.
Thank you so much for your help.
I tried what you have told in the link, but unfortunately failed to make any difference.

Guess I have to do a few more tries to get thru this.
I’ll let you know if I make it.

Thank you, anyway! :slight_smile: