3dwarp - deoblique in fmriprep

Dear all,
I have a fmri dataset that was collected with a 20% oblique angle. To my understanding, this means I need to de-oblique the functional data and then re-orient it, so it would match the standard space.

What is the flag I need to write in fmriprep for this to happen? Could it be “3dWarp -deoblique”? if so, how exactly should I use it and what information I need to write in it?

Alternatively, should I de-oblique the functional data only after fmriprep? if so- how can I do it in fsl?

Thank you very much for your help,

As long as the orientation information is reasonably good, there should be no need to explicitly deoblique your functional data. Are you running into issues with fMRIPrep failing to align your data?

Thank you for the fast reply!
I am not running into such errors, and in general the registrations look pretty good.

However, after I do level-1 analysis in fsl, when I open the outputs in fsleyes (zstats, tstats, cope maps, etc.) together with the standard template, I get the following warning: "Displaying images with different orientations/fields of view! "

I see that all the subjects’s outputs (and also the group-analysis input) are in the same coordinates, whereas the standard template is in different coordinates. I figured it means that all the subjects’ data was standardized, just not completely with the template. Becuase of that, I started thinking that perhaps I need to de-oblique the data in advance, but perhaps I am wrong.

Is there another reason that may cause this warning? I attach a screenshot of it.

Thank you!

This is not an oblique issue at all, but a resampling issue, and it’s not really a problem in itself. FSLeyes is just warning you that the files do not have identical affine matrices and shapes, so you can’t point to the same (I, J, K) index in the data arrays and get the same (R, A, S) coordinate in the template space. But once visualized on top of each other (with their different grids), you can see that the alignment is reasonable.

IIRC FSL bundles a slightly custom MNI template; it’s in MNI space but it’s not exactly the one published by MNI. So that might be causing the issue. Another issue is that you might not have specified to resample in 2mm voxels. Using --output-space MNI152NLin2009cAsym:res-2 will ensure that you get MNI outputs sampled at 2mm instead of in the original resolution of the BOLD image.

1 Like

Great! I did specify the flag --output-space MNI152NLin2009cAsym:res-2, so I guess it means I can ignore this warning.

Thank you very much for the help