AFNI 3dresample "invalid input dataset"

Hi everyone. I am trying to resample a CSF probability image from fmriprep into 2x2x2 resolution using 3dresample in AFNI. Here is the command that I am running:

module load singularity; singularity exec --containall -B /projects/b1081:/projects/b1081 \
/projects/b1081/singularity_images/afni_latest.sif 3dresample -dxyz 2 2 2 \
-prefix /projects/b1108/studies/mwmh/data/processed/neuroimaging/fmriprep/sub-MWMH352/anat/sub-MWMH352_space-MNI152NLin6Asym_res-2_label-CSF_probseg.nii.gz \
-input /projects/b1108/studies/mwmh/data/processed/neuroimaging/fmriprep/sub-MWMH352/anat/sub-MWMH352_space-MNI152NLin6Asym_label-CSF_probseg.nii.gz

Unfortunately, I am getting the following error:

invalid input dataset </projects/b1108/studies/mwmh/data/processed/neuroimaging/fmriprep/sub-MWMH352/anat/sub-MWMH352_space-MNI152NLin6Asym_label-CSF_probseg.nii.gz>

I looked at the image, and it seems totally reasonable. What are the reasons I could be getting this error? Not sure how to debug this. Thank you!

Hm, I don’t see why that would be problematic, even with the very long file/path names. I tried that command with similar filenames on my computer, and it worked OK.

Can you try a simple copy command first, to see that things are fine to I/O that file, from a system point of view:

\cp /projects/b1108/studies/mwmh/data/processed/neuroimaging/fmriprep/sub-MWMH352/anat/sub-MWMH352_space-MNI152NLin6Asym_label-CSF_probseg.nii.gz \



Never mind! I bound the wrong parent directory.