AFNI do not regress motion but censor motion

Hi @ptaylor @rickr @Gang @dglen

I am trying to not regress out motion (mean, derivatives) in the 3ddeconvolve stage of afni preprocessing (-regress_no_motion) , but I do want to censor motion using the and therefore include the (-regress_censor_motion) tag. However, this leads to no motion censoring at all and the files needed for to run are not produced. I am preprocessing multi-echo data so I have:
-dsets_me_run \
echo-01_bold.nii.gz \
echo-02_bold.nii.gz \
echo-03_bold.nii.gz \
-echo_times 14.0 37.87 61.74 \
-out_dir /afni_procs  \
-blocks despike tshift volreg mask combine scale regress \                                                                                
-regress_censor_motion 0.3 \
-regress_no_motion \
-volreg_align_to MIN_OUTLIER \
-combine_method OC

How can I do motion censoring (without regressing out motion) and also generate the files for to run successfully?


Indeed, this does not seem currently possible.

Okay, I added ‘none’ as a possible parameter to -regress_apply_mot_types. We are planning to run a bulid tonight, so this will be available in the morning (or if you are using, you can update right now using ‘-git_tag NONE’).

So replace -regress_no_motion with -regress_apply_mot_types none.

Please let me know if you have any questions about that.

Thanks for the suggestion,

  • rick

Great, thank you for adding the tag, just tried it today and it worked !