Arbitrary Atlas for Freesurfer Volumertic Analysis

Hi everyone,

Freesurfer uses DKT atlas for volumetric analysis by default.
Brainnetome is our favorite one, is there a way to use that?


Hi Majid,

You can find some help here:

Choose: BN_Atlas_freesurfer_Usage.pdf

1 Like

Many thanks @jsein
Unfortunately, I’m confused about the first step of that. It gives me bellow error. Could you help me?

mris_ca_label ‐l /Users/majid/TEST/01/label/lh.cortex.label 01 lh /Users/majid/TEST/01/surf/lh.sphere.reg /Users/majid/TEST/lh.BN_Atlas.gcs /Users/majid/TEST/01/label/lh.BN_Atlas.annot
reading atlas from lh…
error: No such file or directory
error: GCSAread(lh): could not open file
error: No such file or directory
error: mris_ca_label: could not read classifier from lh

Actually I never used these tools but I recently heard about the Brainnetome atlas from a colleague and remembered seeing this document when I read your question.

I tried to reproduce your error and got stuck at the same point with the same error message. Then I understood: If you copy paste the command lines from the PDF, beware of the character ‘-’ ! The ‘-’ you paste from the PDF is not the same than the ‘-’ you type in your terminal. You have to replace them and then it works.

Thank you so much JSein,
I used “” commands and that worked.
Maybe it is necessary to set “SUBJECTS_DIR” first.