ASLprep can't find FS license

I have built a Singularity container with the latest version of ASLPrep and want to run it on a dataset. The data and the ASLPrep image are in the same directory on the host machine – let’s call it /home/usr/myDir, and the FreeSurfer license I want to use with ASLPrep is in a different directory on the host – let’s call it /opt/freesurfer/license.txt. I can’t figure out how to correctly bind the FS license to the Singularity image or allow it to access the license. Can anyone show me the correct command to do this?

Hi @ogoswami, and welcome to neurostars!

Did you look here yet? Usage Notes — aslprep version documentation


Hi @Steven! Yes I did, and I tried including the file path with --fs-license-file as well as with the environment variables, but nothing seems to be working right now. Is the issue that the license is in a different directory than where the Singularity image of ASLPrep?


May you share the command you’ve tried?

I build the image with singularity build aslprep-latest.simg docker://pennlinc/aslprep:latest, and then run with singularity run --cleanenv aslprep-latest.simg --fs-license-file path/to/license ./ASLdata ./ret participant --participant-label 01.

Can you add -b /path/to/license after —cleanenv?

Solved it! I think there was a permissions issue with the license itself. Thank you so much for your help!