Beginners problem with datalad

I try following the datalad 101 tutorial but get errors already on the first create command.
In order to ask for help I ran datalad --version, which gives the same error.

(base) twutz@macadamia tmp> datalad --version
Traceback (most recent call last):
  File "/User/homes/twutz/scratch/twutz/miniconda3/bin/datalad", line 7, in <module>
    from datalad.cmdline.main import main
  File "/User/homes/twutz/scratch/twutz/miniconda3/lib/python3.8/site-packages/datalad/", line 110, in <module>
    cfg = ConfigManager()
  File "/User/homes/twutz/scratch/twutz/miniconda3/lib/python3.8/site-packages/datalad/", line 394, in __init__
  File "/User/homes/twutz/scratch/twutz/miniconda3/lib/python3.8/site-packages/datalad/", line 469, in reload
    self._stores[store_id] = self._reload(runargs)
  File "/User/homes/twutz/scratch/twutz/miniconda3/lib/python3.8/site-packages/datalad/", line 497, in _reload
    stdout, stderr = self._run(
  File "/User/homes/twutz/scratch/twutz/miniconda3/lib/python3.8/site-packages/datalad/", line 878, in _run
    out = + args, **kwargs)
  File "/User/homes/twutz/scratch/twutz/miniconda3/lib/python3.8/site-packages/datalad/runner/", line 201, in run
    raise CommandError(
datalad.runner.exception.CommandError: CommandError: 'git --git-dir= config -z -l --show-origin' failed with exitcode 128 [err: 'fatal: The empty string is not a valid path']

I installed dataled via conda install -c conda-forge datalad on a unix machine where I do not have administrative privileges. Git is already configured and usually works there.

(base) twutz@macadamia tmp> git --version
git version 2.34.1

What part of the installation did I miss?

When I removed the lines similar to the following from my .gitconfig it started to work:

[includeIf "gitdir:**/devbgc/**"]
    path = ~/.gitconfig_bgc

The setup tells git to use different username, email and credentials, i.e. ssh key, when doing work-related things in home-office. It would be nice, if Datalad would support such configurations or at least tell what configurations are supported and which not.

1 Like

Please file an issue at Issues · datalad/datalad · GitHub with such detail - we should crash like that