BIDS-Apps HCPPipelines error


#1

Hi,

I am running into a fatal error in BIDS-Apps HCPPipelines.
The script gets to the “DistortionCorrectionAndEPIToT1wReg_FLIRTBBRAndFreeSurferBBRbased.sh” and then an error message is sent to the screen:


DistortionCorrectionAndEPIToT1wReg_FLIRTBBRAndFreeSurferBBRbased.sh - UNKNOWN DISTORTION CORRECTION METHOD: NONE

Traceback (most recent call last):
File “/run.py”, line 410, in
stage_func()
File “/run.py”, line 139, in run_generic_fMRI_volume_processsing
run(cmd, cwd=args[“path”], env={“OMP_NUM_THREADS”: str(args[“n_cpus”])})
File “/run.py”, line 29, in run
raise Exception(“Non zero return code: %d”%process.returncode)
Exception: Non zero return code: 1


This is the command that I typed:

docker run -i --rm
-v ./BIDS_DATASET:/bids_dataset:ro
-v ./OUTPUTS:/outputs
-v ./license.txt:/license
bids/hcppipelines /bids_dataset /outputs participant --license_key /license
–participant_label 001

How can I fix it?

Best,
Ayumu


#2

@1112 I believe I ran into a similar error - do you have fieldmaps for this dataset? If so, ensure that your IntendedFor field is correct.


#3

Hi,
Thank you for your advice!
Yes! I used phase-difference map method instead of topup method.
I have put “IntendedFor” field as below.
“IntendedFor”: [“func/sub-001_task-rest_run-01_bold.nii.gz”,
“func/sub-001_task-rest_run-02_bold.nii.gz”,
“func/sub-001_task-rest_run-03_bold.nii.gz”]
Is something wrong?
When I ran “fmriprep”, this worked well.
But this did not work for “HCPPipelines”.


#4

Ah, I only have experience with the TOPUP method (spin echo fieldmaps acquired in different phase encoding directions)

FWIW, here’s the script that’s resulting in a failure


#5

Thanks!

In your situation, what was the cause of error?
Did you miss the “IntendedFor” field?


#6

Nope - I was incorrectly assigning field maps within “IntendedFor”