BIDS validator warns README is missing when it is not

Running validator using Docker:
docker run -ti --rm -v /mystudy/rawdata:/data:ro bids/validator --verbose /data > /myoutput/mystudy_bidsvalidator.txt

Output includes:

2: [WARN] The recommended file /README is missing. See Section 03 (Modality agnostic files) of the BIDS specification. (code: 101 - README_FILE_MISSING)
Please visit https://neurostars.org/search?q=README_FILE_MISSING for existing conversations about this issue.

The README file is present in the rawdata directory with permissions 775.

I am also getting the “Maximum call stack size exceeded” error, so perhaps the validator is stopping before it reaches the README file:

    c1: [ERR] Internal error. SOME VALIDATION STEPS MAY NOT HAVE OCCURRED (code: 0 - INTERNAL ERROR)
		.undefined
			Maximum call stack size exceeded; please help the BIDS team and community by opening an issue at (https://github.com/bids-standard/bids-validator/issues) with the evidence here.
			Evidence: RangeError: Maximum call stack size exceeded
    at missingSessionFiles (/src/validators/session.js:17:10)
    at /src/validators/bids/fullTest.js:199:42
    at processTicksAndRejections (internal/process/task_queues.js:94:5)
	Please visit https://neurostars.org/search?q=INTERNAL ERROR for existing conversations about this issue.`

hi @pwrightkcl

thank you for your message. the README error is likely due to the stack size error. perhaps may you please check the validation using the Skip Subject Filename Consistency Check flag on? (for reference)

thank you,
Franklin

1 Like

Thanks @franklin

How do I do this running BIDS in Docker? I’m can’t tell from the Github readme.md (1) how to add Skip Subject Filename Consistency Check to the config file and (2) how to specify a config file in the docker command line. Can I just add the argument as with the bids-validator command, or would it be interpreted by the docker command instead?

Happy to test it out once I know how!

You should be able to put --ignoreSubjectConsistency after --verbose in the command line call. That flag was added somewhat recently so you may need to re-pull or build the docker image.

1 Like

Perfect. That worked. Thank you @rwblair

MANAGED BY INCF