Bidskit dcm2niix version error

Hello,

I’m trying to use bidskit to convert dicom data to bids format, and have an issue.

I installed bidskit with

sudo pip3 install bidskit

and then when I ran it, I got this message.

Check dcm2nixx version
dcm2niix v1.0.20211006 detected - please update to v1.0.20220720 or later

so I updated dcm2niix with

sudo apt-get install dcm2niix

dcm2niix is already the newest version (1.0.20211006-1build1).
0 upgraded, 0 newly installed, 0 to remove and 113 not upgraded.

So I installed the latest dcm2niix separately, but the error message from Bidskit didn’t change.

I’m using ubuntu on Windows.

Is there anyone exprience the same issue?

Thank you very much in advance!

Hi @kay1,

Sounds like an environment issue. Is bidskit installed in a certain environment, like with conda? If so, you can update dcm2niix in that environment (probably with pip as well). I am guessing that whatever is in your environment is superceeding the one you are installing with sudo.

Alternatively, maybe dcm2niix is installed in the Docker container Docker

Best,
Steven

Thank you!

Updating dcm2niix with pip worked!

Best,
Kay

1 Like

You can always find the latest stable release of dcm2niix here, currently v1.0.20230411. Note that Debian systems tend to freeze software at the time of release. The BIDS, DICOM and manufacturers interpretation of DICOM are all evolving rapidly, so I would make sure you ensure you have the latest stable release (in particular if you have a Siemens scanner that was upgraded to XA).