Bug in downloading datasets from openneuro

Not sure if this was reported already, but while trying to download a small BIDS dataset to test VisualQC with, I found the browser-based download interface for openneuro downloads ONLY a json file, and not a dataset (as one would expect).

either I am missing something, or this is a bug.

I tried it with or without signing in, on a couple of datasets.

And the aws command downloads an empty folder for some reason

aws s3 sync --no-sign-request s3://openneuro.org/ds002635 ds002635-download/

Hi @raamana

Thank you for your message! I have documented this issue for ds002635, what other dataset(s) may you have attempted to download a dataset but ran into this bug?

Thank you,
Franklin

I didn’t keep track of all the datasets I tried, but every attempt failed. Just tried 3 datasets: ds002635, ds002647, ds002603, and they all failed on latest Safari on latest macOS.

I’ve also tried to download ds002647 on Firefox 74 on macOS, that failed also. so I think its either a macOS problem or the CDN/data-provider problem.

I presume you noticed my AWS CLI attempt failed also.

thank you for the additional information! I have documented those datasets as having download issues. It appears this has mostly been tested using the browser option to download? Except for ds002647 with the AWS bug you mentioned.

Thank you,
Franklin

yes, mostly browser attempts. Do you have stats on what download interfaces do the openneuro users use? I’d suspect the browser.

We see a split between our command line and web based utilization for downloading. The command line interface tools (AWS and OpenNeuro’s) are strong options. May you please try AWS or our cli tool? I know for ds002635 you mentioned it gave an empty folder.

Thank you for raising this issue. We are tracking a few download issues that are similar to the ones you are experiencing.

Thank you,
Franklin

MANAGED BY INCF