Cannot determine world direction of phase encoding

Hi, I am newbie learning fmriprep. I practiced preprocessing rest-fMRI and t1w data produced in Philips Scanner. I have no fieldmap in BIDS, I trie use --ignore fieldmaps
,but had a same warning message.
RUNNING: docker run --rm -e DOCKER_VERSION_8395080871=20.10.17 -it -v /Users/mac/Desktop/test/test/license.txt:/opt/freesurfer/license.txt:ro -v /Users/mac/Desktop/test/BIDS:/data:ro -v /Users/mac/Desktop/test/BIDS/derivatives:/out nipreps/fmriprep:22.0.0 /data /out participant --participant-label 001 --fs-no-reconall

220910-23:53:44,830 nipype.interface WARNING:
	 Cannot determine world direction of phase encoding. Orientation: LAS; PE dir: None

How could I solve this problem? thanks a lot.


If you have no fieldmaps, fMRIPrep will automatically not do any fieldmap processing, so there is no need to ignore them. You can use the SYN method (--use-syn-sdc) if you still want to perform susceptibility distortion correction (SDC).

In regards to the command you posted:

  1. It is always good to have a pre-specified work directory, which you can pass in with the -w argument.
  2. I do not recommend using the --fs-no-reconall flag, as FreeSurfer T1 outputs improves segmentation and bold-to-t1 registration

Are your data BIDS valid? Do you have phase encoding in your BOLD json files? If not, that could be the problem. How did you convert from dicom to BIDS?


Thanks for your patient reply.

220912-12:46:15,460 nipype.workflow IMPORTANT:
	 fMRIPrep finished successfully!