Configuring remotes on and pushing to Github & GIN

Hi Datalad team,

Here I am again with a second question!

I tried to configure Github an GIN as remotes for my superdataset, which worked fine, as well as pushing to both of them, carefully following the instructions in section 8.2 (particularly 8.2.5) of the handbook.

However, GIN does not allow me to preview my annexed content (which should be the case according to the handbook), it gives me a 404 error when clicking on any of my subdatasets.

Github will not even allow me to click on my subdatasets (which is expected for the annexed content, but they also contain subdirs and files under Git control which I would expect to be able to see/open on Github)? Further, when I try to clone the repo from either Github or GIN, this works, but the subdatasets are completely empty, even the parts under Git control do not appear.

Here is my github repo: https://github.com/labgas/proj_discoverie

Thanks a lot in advance again!

Best wishes,

Lukas

Gin - most likely you didn’t transfer annexed content to it.
GitHub - check urls in .gitmodules . The repo you pointed to 404s for me (private?)

Thanks!

I followed the instructions in 8.2. Dataset hosting on GIN — The DataLad Handbook, more specifically section 8.2.5.

I did notice in section 8.2.2 however that the output reads

    The authenticity of host 'gin.g-node.org (141.84.41.219)' can't be established.
ECDSA key fingerprint is SHA256:E35RRG3bhoAm/WD+0dqKpFnxJ9+yi0uUiFLi+H/lkdU.
Are you sure you want to continue connecting (yes/no)? yes
[INFO   ] Failed to enable annex remote gin, could be a pure git or not accessible
[WARNING] Failed to determine if gin carries annex.
.: gin(-) [git@gin.g-node.org:/adswa/DataLad-101.git (git)]

I got the same output when executing my command, and wonder whether that could be the problem

Thanks,

Lukas

I removed both repos, but will push them back in a few days.

Any specific instructions as to how to transfer annexed content when pushing to GIN, in addition to the handbook instructions I followed (see my previous post)?

Thanks!

Just make sure that gin remote url doesn’t have .git at the end.

Thanks Yarik!

Here is my command and the output it generates (similar to the handbook)

u0027997@gbw-s-labgas01:/data/proj_discoverie$ datalad siblings add -d . --name gin-update --pushurl git@gin.g-node.org:/labgas/proj_discoverie.git --url https://gin.g-node.org/labgas/proj_discoverie --as-common-datasrc gin
Enter passphrase for key '/home/luna.kuleuven.be/u0027997/.ssh/id_ed25519':
[INFO   ] Could not enable annex remote gin-update. This is expected if gin-update is a pure Git remote, or happens if it is not accessible.
[WARNING] Could not detect whether gin-update carries an annex. If gin-update is a pure Git remote, this is expected. Remote was marked by annex as annex-ignore. Edit .git/config to reset if you think that was done by mistake due to absent connection etc
.: gin-update(-) [https://gin.g-node.org/labgas/proj_discoverie (git)]

Then, as per instructions, I ran the following command in my superdataset, which did not generate output

 git config --unset-all remote.gin-update.annex-ignore

Finally, I pushed using

datalad push --to gin-update

This works, but clicking on any of my subdatasets results in 404, even the code subdataset which should not have anything annexed!

Any help would be welcome again!

Best wishes,

Lukas

Contrary to earlier attempts, I do not manage to set up a sibling on Github anymore

u0027997@gbw-s-labgas01:/data/proj_discoverie$ datalad create-sibling-github -d . -s github --github-organization labgas proj_discoverie
[ERROR  ] InitError(Failed to create the collection: Prompt dismissed..) (InitError)

Any idea what could cause this error (which I did not have before with an identical command)?

It did work manually (creating an empty repo on Github), then using datalad siblings add …, and then datalad push.

This works (https://github.com/labgas/proj_discoverie) but my problem is the same as before: I cannot open any of the subdataset folders, even not code which has everything stored in git, so I cannot open nor link to any of the scripts in it.

Following your earlier suggestion, I checked the urls in .gitmodules, and they are basically all of the form ./<subdataset_name>. Is that expected?

Please note my default branch after pushing was git-annex, which I changed to master, but the problem was already present before this switch.

Thanks,

Lukas

MANAGED BY INCF