Coregistration of multi-echo data using fMRI prep v1.2.5

Hi NeuroStars,

I’m currently running fMRI Prep v1.2.5 on ME-data with the following flags (see below), but seem to be running into some coregistration issues:


module load fmriprep/1.2.5

Run fmriprep

–participant-label ${subject}
–output-space {T1w,template}
–mem_mb 80000
-n-cpus 8
–fs-license-file ${fslicense}
-w ${workdir}

When checking the coregistration between the 'fung/sub-label_task-label_run-1_space-MNI152NLin2009cAsym_desc-preproc_bold.nii.gz` file and MNI atlas (Asym 2009c; they seem to look off. I’ve tried with and without the call for FreeSurfer, and below are the results.

no Freesurfer:

with Freesurfer ( note: "–fs-no-reconall " flag was removed)

I’ve also noted in one of the topics on NeuroStars that the --output-space is space delimited. Therefore, I tried "–output-space Tw template ". Below is the resulting image.

T1_preproc to MNI

Any reason why this could be happening? Happy to share more information if needed :slight_smile:

Link to dataset:

Thank you.

Hi @TribikramT,

That definitely doesn’t look right ! I just requested access to the data to look into it. I wonder if it’s related to this issue:


Could you share the corresponding report? (e.g., could you place it on /derivatives/fmriprep_1.2.5 under the root of the shared dataset?)

Please make sure that you also include the sub-XYZ/figures/ folder.

Is this happening for all, most, few or just one of your participants?

Hi @emdupre

I don’t think its a similar issue. However, I could be wrong as I am still new to ME and fMRI in general.

I have given you access to the link shared above. With your experience, you may have a better understanding of what is going on. Thank you for your help :slight_smile:

Hi @oesteban

All files are in the link mentioned above. Please could you click the link so that I can give you access to the data.

I am currently running Pilot sessions. This is the first time I’ve come across this issue, and want know if I was doing something wrong.

Thank you.

Hi @emdupre @oesteban ,

Just following up. Have you been able to replicate my issue?