Data.ecclog not saved when running workflow

I created a workflow that applies EddyCorrect to the data, but when I run the workflow the file data.ecclog is not saved (however if I run the EddyCorrect node on its own then the file is saved). I tried to change the config dictionary in both the eddycorrected node and in my workflow, but to no avail…

subject_list = ["01","02"]

infosource = Node(IdentityInterface(fields=["subject_id"]), name="infosource")
infosource.iterables = [("subject_id", subject_list)]

template = {"outfile": os.path.join("sub-{subject_id}", "data.nii.gz")}
selectfiles = Node(SelectFiles(template, base_directory="\data"), name="selectfiles")

eddycorrect = Node(fsl.EddyCorrect(out_file="data.nii.gz"),name="eddycorrect")    

wf = Workflow(name="wf", base_dir=\data)    

wf.connect(infosource, "subject_id", selectfiles, "subject_id")
wf.connect(selectfiles, "outfile", eddycorrect, "eddy_corrected")'MultiProc')

I wonder if I can somehow instruct DataSink to save the data.ecclog file. However EddyCorrect has only eddy_corrected as output, so I don’t know how to specify that. Could someone please help me?

@mri the EddyCorrect interface is deprecated in Nipype, you should try using the Eddy interface instead - it has many more outputs