Datalad install problem ds002393


I tried to install ds002393 using datalad, but I ran into problems. Here is my output:

The issue seems to be similar to the one reported here: Cannot find latest version when updating #datalad datasets

Thank you for your help

Hi @alexfoias

I apologize for the delayed response! It appears we have a remote for this dataset. It looks like the whole dataset is failing where previously it was certain files or grabbing a previous version (perhaps due to tags on GitHub). @yarikoptic may perhaps see something on the Datalad side

Thank you,

A quick workaround - just do git annex enableremote s3-PUBLIC manually in any new clone of any openneuro repository which was published to s3 after about Jan 6th and it will all work:

$> datalad install && cd ds002393 && git annex enableremote s3-PUBLIC && datalad get *
[INFO   ] Scanning for unlocked files (this may take some time)                                                                                                                    
[INFO   ] Remote origin not usable by git-annex; setting annex-ignore                                                                                                              
install(ok): /tmp/ds002393 (dataset)
datalad install  6.44s user 2.69s system 90% cpu 10.058 total
CHANGES                   participants.json  sub-chibaIngenia/  sub-juntendo750w/     sub-juntendoSkyra/  sub-perform/    sub-tokyoIngenia/  sub-tokyoSkyra/
README                    participants.tsv   sub-douglas/       sub-juntendoAchieva/  sub-mghBay3/        sub-poly/       sub-tokyoSigna1/   sub-ucl/
dataset_description.json  sub-chiba750/      sub-glen/          sub-juntendoPrisma/   sub-oxford/         sub-tokyo750w/  sub-tokyoSigna2/   sub-unf/
enableremote s3-PUBLIC ok
(recording state in git...)
Total (2 ok out of 130):   2%|█▉                                                                                                               | 14.2M/810M [00:02<02:36, 5.09MB/s^C[WARNING] Still have 11 active progress bars when stopping                                                                                                                        
Interrupted by user while doing magic: KeyboardInterrupt() []