Dcm2bids fails to convert multi echo anatomical SPGR

Hi everyone,

I have encountered a problem in converting multi echo anatomical SPGR dicoms to BIDS format using dcm2bids (version 2.1.5, on Ubuntu 16.04).

Specifically, there is no pairing for the different echoes:

:No Pairing  <-  015_S003_t1_fl3d_FA10_20210105111149_e1
    INFO:dcm2bids.sidecar:No Pairing  <-  015_S003_t1_fl3d_FA10_20210105111149_e2
    INFO:dcm2bids.sidecar:No Pairing  <-  015_S003_t1_fl3d_FA10_20210105111149_e3

I attempted to fix this by adding the customLabels key-value, following this suggestion, but the problem persists.
My bids_config.json file has entries such as:

         "dataType": "anat",
         "modalityLabel": "T1map",
         "customLabels": "acq-fa10_echo-1",
         "criteria": {
            "SidecarFilename": "*_e1",
            "SeriesDescription": "t1_fl3d_FA10"

It seems that others have been able to complete such conversions successfully.

Any idea what I may be doing wrong?
Any help would be greatly appreciated!

Many thanks,

Dear @roeysc,
Can you share with me the json files of your anatomical images ?
I will check, why your bids config file is not grabbing this.

Hi @roeysc,

Using "SidecarFilename": "*_e1" doesn’t catch anything since it’s not a key in your json file.

To catch the different echoes you have two options.

  • Option 1:
    "EchoNumber": 1
  • Option 2:
    "EchoTime": 0.00334

Option 2 can be tricky if you don’t have the exact same echo time for each participant.
The order should stay the same so I would suggest you to use option 1.

Obviously, change the number of the echo for each image.


Hi @abore,
Thank you so much. This makes perfect sense (I was under the impression that SiecarFilename was not a key in the json file, but rather the actual name of the json file). Now the conversion works smoothly.
Many thanks for your kind help,

Hi @roeysc ,

Can you tag this discussion as solved ? It helps us to sort the different threads.
I think, you just need to click on the button response under my response.

Thank you

Absolutely. Thanks for pointing that out!