Dhcp structural pipeline measure docker only T2


I am trying to use the dhcp docker for the pipeline measures but I am not sure if it will work with only T2 images. I do not have enough usable T1 images for this data set. When I run it I get ‘no T1 for session-1’. Thanks!


Hi @ajdneuro,

Yes, you can run the structural pipeline without T1 images. However, this means you won’t get myelin maps for your subjects (T1w/T2w ratio). What command are you using for the structural pipeline?

Best wishes,


Hi Logan,

Thanks! I ran the pipeline, just the script (docked) for calculating the measures is not working without the T1s.


Hi Alex,

If you are using the command as per the BioMedIA GitHub here:

$ docker run --rm -t \
    -u $(id -u):$(id -g) \
    -v $PWD/data:/data \
    biomedia/dhcp-structural-pipeline:latest subject1 session1 44 \
            -T1 data/T1w.nii.gz -T2 data/T2w.nii.gz -t 8

You just need to remove the -T1 flag. Let me know if that doesn’t work :slight_smile:


Sorry I mean these scripts:

At what point in the pipeline are you getting this error?

When I run the docker image and point it to the derivates it gives this error:
pa0639 no T1 for session session-1

Hi Logan,

I am using only T2-w image using the following command:

docker run --rm -t
-u (id -u):(id -g)
-v $PWD/data:/data
biomedia/dhcp-structural-pipeline:latest sub-NYS1553 ses-001 43
-T2 data/sub-NYS1553_ses-001_T2w.nii.gz -t 8

but I am getting Surface, Segmentation and additional errors.
I have attached the log and error files.

sub-NYS1553-ses-001.additional_log.txt (3.6 KB)
sub-NYS1553-ses-001.segmentation_err.txt (12.2 KB)
sub-NYS1553-ses-001.segmentation_log.txt (120.7 KB)
sub-NYS1553-ses-001.surface_err.txt (2.6 KB)
sub-NYS1553-ses-001.surface_log.txt (1.2 KB)

Your help is highly appreciated,