Dipy.viz.window.record aborting

Hello all!

I am following some the Reconstruction with Constrained Spherical Deconvolution tutorial from dipy. Everything seems to be working by visualization is not at all. window.record and window.snapshot both cause my program to abort. I tried entering debugging mode and still it just told me abort, no clues. I have dipy 1.7.0 and fury 0.9.0 installed. All the dependencies (scipy, numpy etc) were installed in accordance with this dipy version. Everything else works, just this continously aborts.

Any clues how to fix this?

Thanks!
Hank

Hey Hank – welcome to Neurostars! :brain: :star:

Could you tell us a little bit about how/where you are running this? For example, what operating system are you working on? Sometimes these graphics-related functions don’t work when you are in working on a “headless computer”, such as a remote server that you log into. In those cases, you can still use XVFB to run these functions. I tend to use the xvfbwrapper library for this. From their examples:

from xvfbwrapper import Xvfb

vdisplay = Xvfb()
vdisplay.start()

# DIPY code that includes window.record and window.snapshot in here

vdisplay.stop()

Hello Ariel - Thank you and thanks for the quick reply!!

I am using a linux HPC cluster. I tried using this Xvfb wrapper to no avail. Here is the gdb output:

Program received signal SIGABRT, Aborted.

0x00007ffff6976387 in raise () from /lib64/libc.so.6

Any thoughts?

Thanks again!
Hank

No - sorry - I have no idea what that means.