Discarded acquisitions- should I do it before or after fmriprep preprocessing?

Hi,
I have an fMRI data that was collected without a dummy scan at the beginning. Accordingly, I need to drop the first 4 TRs from the analysis. I am wondering how, and when, it should be done?

Is there a flag that enables me to do that within the fmriprep code? I saw in a previous thread that I can use the command ‘Dummy scans = ROUNDUP(3001/TR)’, but I am not sure what it does and how it relates to the specific number of TRs I wish to erase?
Alternatively, can I do the preprocessing with all the data and discard the first 4 TRs afterwards, when I continue to the level-1 analysis in FSL? If so, how does it affect the preprocessing results and the data?

Thank you very much,
Lior

In the fmriprep command line, you may use: ( I never used it but it looks like it does what you want)

--dummy-scans
Number of nonsteady-state volumes.

https://fmriprep.org/en/stable/usage.html#Workflow%20configuration

Alternatively, fmriprep is calculating the number of non-steady state volumes for each run and you may remove those after the fmriprep preprocessing. You would then need to remove the corresponding number of lines for the columns that you will use from the confounds_timeseries.tsv file to adapt for the number of volumes kept in the analyses.
Or, you could just censor those volumes in your GLM analysis.

1 Like

Additional insight on what --dummy-scans does in fmriprep workflow:

https://fmriprep.org/en/stable/faq.html?highlight=dummy#error-in-slice-timing-correction-insufficient-length-of-bold-data-after-discarding-nonsteady-states

1 Like

Thank you so much for the detailed answer!
I followed your advice and used --dummy-scans 4.

I know for sure that the code recognized this command, since it is written in the ‘about’ section in the html output. But, there is no mentioning of it in the ‘methods’ section.

The only possible indication that it worked, I think, is that in the confound.tsv file, the first 4 TRs of the tcompcor and acompcor regressors are zeros, whereas before, only the first 2 TRs were zeros.

Could it be that before I put the dummy flag, fmriprep recognized the first 2 TRs as dummy TRs and because of that put zeros in all the compcor vars, and now it forced it to do the same on the first 4 TRs?

Thank you so much for the help