Error in fmriprep involving PatchedBBRegisterRPT

Hi,
I’m preprocessing an fmri dataset with fmriprep (3T, single-band, rather low contrast in EPI images). The standard fmriprep settings worked overall very well, but the EPI to T1 registration could be a bit better (offsets in some, but not all participants). I suspect the surface based registration of bbregister to have trouble because of the low contrast in EPI images.

I now ran fmriprep with the following command to co-register differently:

fmriprep-docker BIDS_path derv_path/derivatives_02_no_bbr participant --work-dir tmp_path --fs-license-file freesurfer_license_file --force-no-bbr --use-aroma --output-spaces output_spaces --participant-label test_subjects

which results in the following crash report for each participant:

Node: fmriprep_wf.single_subject_DS160531_wf.func_preproc_ses_1_task_rest_wf.bold_reg_wf.bbreg_wf.bbregister
Working directory: /scratch/fmriprep_wf/single_subject_DS160531_wf/func_preproc_ses_1_task_rest_wf/bold_reg_wf/bbreg_wf/bbregister

Node inputs:

args = <undefined>
compress_report = auto
contrast_type = t2
dof = 6
environ = {'SUBJECTS_DIR': '/opt/freesurfer/subjects'}
epi_mask = <undefined>
fsldof = <undefined>
init = <undefined>
init_cost_file = <undefined>
init_reg_file = <undefined>
intermediate_file = <undefined>
out_fsl_file = <undefined>
out_lta_file = True
out_reg_file = <undefined>
out_report = report.svg
reg_frame = <undefined>
reg_middle_frame = <undefined>
registered_file = True
source_file = <undefined>
spm_nifti = <undefined>
subject_id = <undefined>
subjects_dir = /opt/freesurfer/subjects

Traceback (most recent call last):
  File "/usr/local/miniconda/lib/python3.7/site-packages/nipype/pipeline/plugins/multiproc.py", line 67, in run_node
    result["result"] = node.run(updatehash=updatehash)
  File "/usr/local/miniconda/lib/python3.7/site-packages/nipype/pipeline/engine/nodes.py", line 516, in run
    result = self._run_interface(execute=True)
  File "/usr/local/miniconda/lib/python3.7/site-packages/nipype/pipeline/engine/nodes.py", line 635, in _run_interface
    return self._run_command(execute)
  File "/usr/local/miniconda/lib/python3.7/site-packages/nipype/pipeline/engine/nodes.py", line 723, in _run_command
    cmd = self._interface.cmdline
  File "/usr/local/miniconda/lib/python3.7/site-packages/nipype/interfaces/base/core.py", line 731, in cmdline
    self._check_mandatory_inputs()
  File "/usr/local/miniconda/lib/python3.7/site-packages/nipype/interfaces/base/core.py", line 264, in _check_mandatory_inputs
    raise ValueError(msg)
ValueError: PatchedBBRegisterRPT requires a value for input 'subject_id'. For a list of required inputs, see PatchedBBRegisterRPT.help()

Any help on how to fix this problem with PatchedBBRegisterRPT is highly appreciated! Thank you.

Best,
Antonius

I am running into the same error, and I am wondering how you were able to resolve it.

Hi,
no, unfortunately not.

Best,
Antonius

MANAGED BY INCF