Error in "native" EPI space processing (--output-spaces func)

fmriprep
#1

Hello stars,

I’ve been trying to run fmriprep in the “native” EPI space. My understanding is that since version 1.4 this is available (# fMRIPrep: preprocessed data in native BOLD space) using the “–output-spaces func” argument.

I updated my docker version from 1.3 to 1.4 and tried:

fmriprep-docker $Fmri_preproc_in_folder $Fmri_preproc_out_folder participant --participant-label $Subj --fs-license-file $Fs_lic_file -vvv -w $work_dir --nthreads 2 --omp-nthreads 4 --mem-mb 14000 --low-mem --output-spaces func

However theres an error I can’t work out. I do not see anything of help in the workdir either.

The output from fmriprep is:

fmriprep-docker /Volumes/nfs/drorcohen/data/fmripreproc_test_bidsdata/ /Volumes/nfs/drorcohen/data/fmripreproc_test_output/ participant --participant-label sub-002 --fs-license-file /Volumes/nfs/drorcohen/data/fmripreproc_scripts/license.txt -vvv -w /Users/drorcohen/Documents/fmriprep_work_dir/ --nthreads 2 --omp-nthreads 4 --mem-mb 14000 --low-mem --output-spaces func
RUNNING: docker run --rm -it -e DOCKER_VERSION_8395080871=18.09.2 -v /Volumes/nfs/drorcohen/data/fmripreproc_scripts/license.txt:/opt/freesurfer/license.txt:ro -v /Volumes/nfs/drorcohen/data/fmripreproc_test_bidsdata:/data:ro -v /Volumes/nfs/drorcohen/data/fmripreproc_test_output:/out -v /Users/drorcohen/Documents/fmriprep_work_dir:/scratch poldracklab/fmriprep:1.4.1 /data /out participant --participant-label sub-002 -vvv --nthreads 2 --omp-nthreads 4 --mem-mb 14000 --low-mem --output-spaces func -w /scratch
Making sure the input data is BIDS compliant (warnings can be ignored in most cases).
1: [WARN] The recommended file /README is missing. See Section 03 (Modality agnostic files) of the BIDS specification. (code: 101 - README_FILE_MISSING)

Please visit https://neurostars.org/search?q=README_FILE_MISSING for existing conversations about this issue.


    Summary:                 Available Tasks:        Available Modalities: 
    69 Files, 12.65GB        PView                   T1w                   
    3 - Subjects                                     bold                  
    3 - Sessions                                                           


If you have any questions, please post on https://neurostars.org/tags/bids.

Although --fs-no-reconall was not set (i.e., FreeSurfer is to be run), no FreeSurfer output space (valid values are: fsaverage5, fsaverage, fsaverage6, fsnative) was selected. Adding default “fsaverage5” to the list of output spaces.
190717-03:00:24,353 nipype.workflow WARNING:
Per-process threads (–omp-nthreads=4) exceed total threads (–nthreads/–n_cpus=2)
190717-03:00:24,357 nipype.workflow IMPORTANT:

Running fMRIPREP version 1.4.1:
  * BIDS dataset path: /data.
  * Participant list: ['002'].
  * Run identifier: 20190717-030024_1ca7ecb2-88bc-41eb-9630-ee08975544eb.

190717-03:00:25,579 nipype.workflow IMPORTANT:
Creating bold processing workflow for “/data/sub-002/ses-1/func/sub-002_ses-1_task-PView_acq-TR1000_run-1_bold.nii.gz” (0.42 GB / 630 TRs). Memory resampled/largemem=1.67/4.29 GB.
190717-03:00:25,579 nipype.workflow IMPORTANT:
No single-band-reference found for sub-002_ses-1_task-PView_acq-TR1000_run-1_bold.nii.gz
190717-03:00:27,155 nipype.workflow IMPORTANT:
Slice-timing correction will be included.
Process Process-2:
Traceback (most recent call last):
File “/usr/local/miniconda/lib/python3.7/multiprocessing/process.py”, line 297, in _bootstrap
self.run()
File “/usr/local/miniconda/lib/python3.7/multiprocessing/process.py”, line 99, in run
self._target(*self._args, **self._kwargs)
File “/usr/local/miniconda/lib/python3.7/site-packages/fmriprep/cli/run.py”, line 610, in build_workflow
work_dir=str(work_dir),
File “/usr/local/miniconda/lib/python3.7/site-packages/fmriprep/workflows/base.py”, line 259, in init_fmriprep_wf
use_syn=use_syn,
File “/usr/local/miniconda/lib/python3.7/site-packages/fmriprep/workflows/base.py”, line 609, in init_single_subject_wf
use_syn=use_syn,
File “/usr/local/miniconda/lib/python3.7/site-packages/fmriprep/workflows/bold/base.py”, line 551, in init_func_preproc_wf
if ‘MNI152NLin2009cAsym’ in volume_std_spaces else next(iter(volume_std_spaces))
StopIteration
fMRIPrep: Please report errors to https://github.com/poldracklab/fmriprep/issues

Any help appreciated.

Thanks

#2

I have managed a workaround.

The issue is solved by adding MNI152NLin2009cAsym as one of the output spaces. Seems closely related to this https://github.com/poldracklab/fmriprep/issues/1675, which is on the 1.4.2 milestone https://github.com/poldracklab/fmriprep/milestone/28, so this may get fixed in the next version

#3

That is correct, alternatively you could use the pre-release 1.5.0rc1, although as a release candidate it can be not stable enough.

1 Like