Error in the coregistration of B0 to T1W

Summary of what happened:

When using QSIPrep, there’s an issue with coregistering my DTI image and the T1w. What can I do to resolve this? I’ve already tried several combinations of the options available for dwi-to-Anatomical coregistration, and the bet is being done correctly.

Command used (and if a helper script was used, a link to the helper script or the command generated):

qsiprep-docker /home/pisa/Desktop/DTI/bids_AP /home/pisa/Desktop/DTI/derivatives_75_AP participant --participant-label 01 --recon_input /home/pisa/Desktop/DTI/derivatives_75_AP --recon_spec dsi_studio_gqi --fs-license-file /media/pisa/0ABA196EBA195811/Ubuntu/license.txt --use-syn-sdc --write-graph --output_resolution 1



Environment (Docker, Singularity / Apptainer, custom installation):


Data formatted according to a validatable standard? Please provide the output of the validator:


Screenshots / relevant information:


Looking at that screenshot makes me wonder if there isn’t anything cropped off the raw DWI image. Do you have PA scans such that you can do better SDC?

Also --recon_input /home/pisa/Desktop/DTI/derivatives_75_AP is only needed if you are only doing recon (combined with --recon-only).


Hi, @Steven!
I did what you suggested, but the error still persists. Upon examining the ‘Workdir’, the native space is perfectly fitted.

Did you look at the raw DWI image? Provide a screenshot?

Hi Steve!
Sorry for not being in the lab at the moment. As soon as I’m there, I can send the screenshot. But I wanted to mention that I took a look at the RAW data and the DTI fits perfectly into the T1w image in native space.
Additionally, the FA map has a part of the skull (bet was not done correctly), but apparently everything is okay with the DTI.
Best regards!

Could this be a concatenation issue? Because I’m working with a subject having two DWI (multishell) files.

Do you concatenate them in QSIPrep or afterwards? I see you have a BIDS AP, which implies you might be separating your data, which would not be recommended.

Hi, @Steven !
This is my bids directory:

I thought QSIPrep automatically concatenated through the BIDS organization. What can I add to my code line so that QSIPrep concatenates?

Do you have a bids_PA too? It sounded like you might have been separating your AP and PA scans.

Yes, I have both AP and PA scans. With the PA scans, the processing also yielded a poor coregistration result.

You should have a single bids directory containing both your AP and PA scans (with the dir-<> label added to the filenames).


1 Like

Thank you for letting me know. I’ll attempt to process it accordingly.

I ran qsiprep again as instructed, but I’m still encountering an error with image registration. I also attempted to perform BET on the DWI images prior to execution, but all my attempts yielded the same outcome.

Command used

qsiprep-docker /home/pisa/Desktop/DTI/bids /home/pisa/Desktop/DTI/derivatives participant --participant-label 01 --recon_spec dsi_studio_gqi -w /home/pisa/Desktop/DTI/work --fs-license-file /media/pisa/0ABA196EBA195811/Ubuntu/license.txt --anatomical-template MNI152NLin2009cAsym --write-graph --output_resolution 1


Can you share a screenshot of raw DWI data to ensure whole brain coverage?


in your screenshots, what is the T1w in the underlay? is it your raw T1w from BIDS or is it the desc-preproc_T1w in the qsiprep outputs?

The last screenshot is the raw data, while the others depict the output of the QSIPrep processing.

For both the dwi and the t1w?

Yes, for all of them.