Events files unrecognised by OpenNeuro

openfmri

#1

Hello,

I am trying to upload a dataset comprising EEG and fMRI data simultaneously acquired but I am experiencing a number of problems and I was hoping to get some assistance from you.

Basically I have two main problems

  1. how to upload the EEG data in a BIDS compatible format (I tried to use .bidsignore without luck)
  2. how to create the events.tsv files to go with the fMRI files (the events files I created are not recognised when I upload them)

Regarding the second issues, I built tsv files and saved them with names matching the fMRI data in the individual subject folder. However when I upload the dataset I get the error “Second column of the events file must be named ‘duration’”.

Now the tsv files were obtained saving in tsv format an excel sheet with two columns labelled onset and duration, as prescribed. ‘onset’ and ‘duration’ appears in the top row of the tsv files separated by a tab. However in the error specs it says that the error lies in Line: 1 Character: 6 onsetduration as if the tab character was not detected.

Should I do something differently?


#2

Could you share the problematic file here?


#3

I can’t upload it (it has to be a jpeg/png/jif to do so here)

That’s what’s inside (copied and paste):
onset duration
2.148 1.25
6.747 1.25
10.729 1.25
14.994 1.25
17.709 1.25
21.675 1.25
26.29 1.25
28.689 1.25
32.321 1.25
35.37 1.25
39.985 1.25
42.717 1.25
45.433 1.25
48.465 1.25
50.881 1.25
53.297 1.25
58.528 1.25
60.944 1.25
64.276 1.25
67.625 1.25
70.357 1.25
74.022 1.25
76.755 1.25
79.171 1.25
82.203 1.25
84.918 1.25
90.133 1.25
93.465 1.25
98.38 1.25
102.662 1.25
106.028 1.25
109.06 1.25
112.409 1.25
115.741 1.25
120.955 1.25
124.321 1.25
129.219 1.25
133.201 1.25
138.433 1.25
141.165 1.25
145.447 1.25
147.862 1.25
152.144 1.25
154.527 1.25
159.642 1.25
163.007 1.25
166.989 1.25
170.971 1.25
174.636 1.25
177.052 1.25
180.417 1.25
184.633 1.25
187.981 1.25
191.33 1.25
194.995 1.25
199.594 1.25
204.209 1.25
206.625 1.25
210.906 1.25
213.639 1.25
218.87 1.25
222.219 1.25
226.201 1.25
231.283 1.25
234.931 1.25
237.347 1.25
241.312 1.25


Allow users to upload text files
#4

It’s hard to judge from a copy/paste. The bottom line is that the column separators need to be tabs (not spaces). You can verify if your file is using tabs by opening it in a text editor such as Atom or https://www.sublimetext.com/3.

Here are instructions for exporting tab separated value files using Excel.


#5

they are indeed separated by tabs (as checked through sublimetext also). From excel I can only export .txt when tab separated. But events.txt files aren’t read when uploading to openNeuro they have to have a .tsv extension, which is an additional burden in a way because I have to rename them manually.

I can send you the files to you somehow?


#6

chrisgor@stanford.edu


#7

Hi Chris,

I have sent you one of the files which is giving me an error now.

Best
A


#8

Thanks for sending the file. There are couple of issues

  1. There are only two columns in your file. This is valid but due to a bug in the validator causes an error. I cannot give you a timeline for fixing this bug, but I find it unlikely that one would be able to replicate the analysis with only those two columns. Ale the _events files I’ve seen had more columns denoting event properties such as trial_type or various covariates (accuracy, response_time etc.). Files with more than two columns pass the validator.

  2. The second issue is more subtle. There was something wrong with the encoding of the text file you sent me? How was it created? When I resaved it with UTF-8 encoding the error went away. I tried using Excel to export those file (not really the recommended way, but I assumed this is what was used), but it also did not create encoding issues. You can read more about programmatically writing TSV files here: https://github.com/INCF/bids-starter-kit/wiki/Metadata-file-formats#tsv-files

I hope this helps!


#9

Hi, I have tried adding a third column specifying the trial type and it seems to be working.
I’ll try to upload the entire dataset now.

  1. the files I had sent you were text files resaved as tsv files by renaming manually the extension

A final note. I have troubles signing in from chrome


#10

Using orcid or Google?


#11

Using google.

With mozilla it works fine instead.


#12

Sorry to hear that. If you can share that subject I can have a look.


#13

Hi Chris, I shared a subject, please let me know your thoughts


#14

I have not received anything. How did you share the data?


#15

I had sent it to the noreply address :smiley:

now I have sent it to chrisgor@stanford.edu, let me know if you have received it.