Fielmap data not used

Hello Neurostars,

fMRIprep (23.1.4) does not take the magnitude1 and phase files for correction, as it reports “Susceptibility distortion correction: None”. The fmap files are not mentioned anywhere, and they should be both named correctly according to BIDS (generated by nii2bids) under the fmap folder and contain the intendedFor sidecar (everything passes bids validation).


Both containing:
“IntendedFor”: [

I have triple echo acquisition, I tried to point to the first echo, and to all 3 in the intendedFor, nothing changed.

magnitude1 is for the shortest echo, and phasediff.json contains info on both echos. I also added magnitude2 but did not help. They are generated by a gre_field_mapping_AP scanner sequence.

Running fMRIprep in singularity, reports that it finished successfully with no errrors.


Hi @julian1 and welcome to neurostars!

Fmriprep at the moment does accept BIDS URI for IntendedFor (that is, the bids::sub-101 part). Remove that and have each entry begin with ses-01 and it should work.


Thanks Steven,

This worked fine, I’ll try to make the deletion automatic in the dcm2bids configuration file if that would be possible with the “post_op” function.