FileNotFound problem with fmriprep-docker

Summary of what happened:

Please help! I have tried to create a sub-folder in the scratch dir, tried to remove bids_validation (flag), tried to specify --mem-mb 30000 (for example) but i a debugging this for a colleague (since i manage the server on which we run this, but i ve never used fmriprep myself and so am not familiar with this environment and my collegue neither has any idea of what this error might be related to …) - we both have admin rights,- i have absolutely no idea what the problem might be and the error message does not specify any file so …

Command used (and if a helper script was used, a link to the helper script or the command generated):

fmriprep-docker \
$bids_root_dir/sourcedata \
$bids_root_dir/derivatives \
participant \
--participant-label $subj \
--fs-license-file $HOME/license.txt \
--task-id 'visuoWM' \
--md-only-boilerplate \  --fs-no-reconall \
 --skip-bids-validation \
 --output-spaces MNIPediatricAsym:cohort-2:res-1  \
--stop-on-first-crash \
 --fd-spike-threshold 1  \
--dvars-spike-threshold 10 \
 -w /scratch



Environment (Docker, Singularity / Apptainer, custom installation):


Data formatted according to a validatable standard? Please provide the output of the validator:


Relevant log outputs (up to 20 lines):

RUNNING: docker run --rm -e DOCKER_VERSION_8395080871=20.10.7 -it -v /home/guedjc/license.txt:/opt/freesurfer/license.txt:ro -v /home/guedjc/ORBIT_analysis/sourcedata:/data:ro -v /home/guedjc/ORBIT_analysis/derivatives:/out -v /scratch/fmriprep_workdir:/scratch nipreps/fmriprep:24.0.0 /data /out participant --participant-label 051 --task-id visuoWM --md-only-boilerplate --fs-no-reconall --skip-bids-validation --stop-on-first-crash --fd-spike-threshold 1 --dvars-spike-threshold 10 -w /scratch --output-spaces MNIPediatricAsym:cohort-2:res-1
Traceback (most recent call last):
  File "/opt/conda/envs/fmriprep/bin/fmriprep", line 8, in <module>
  File "/opt/conda/envs/fmriprep/lib/python3.11/site-packages/fmriprep/cli/", line 96, in main
    retval = mgr.dict()
  File "/opt/conda/envs/fmriprep/lib/python3.11/multiprocessing/", line 727, in temp
    token, exp = self._create(typeid, *args, **kwds)
  File "/opt/conda/envs/fmriprep/lib/python3.11/multiprocessing/", line 607, in _create
    conn = self._Client(self._address, authkey=self._authkey)
  File "/opt/conda/envs/fmriprep/lib/python3.11/multiprocessing/", line 519, in Client
    c = SocketClient(address)
  File "/opt/conda/envs/fmriprep/lib/python3.11/multiprocessing/", line 647, in SocketClient
FileNotFoundError: [Errno 2] No such file or directory
fMRIPrep: Please report errors to```

### Screenshots / relevant information:
<!-- Below this line, provide any other information that might be meaningful. This could be screenshots, troubleshooting steps you have tried, or information about your operating system, etc. -->


Hi @AlanTuring and welcome to neurostars!

For future posts like this, please use the Software Support category which provides a template you can follow to provide us with more information. You can see that I have reorganized your post for you this time.

That doesn’t look right. First argument of fmriprep should be the BIDS root directory, not sourcedata. Also it is not recommended to do --fs-no-reconall. You can get the BIDS validation report by not --skip-bids-validation.


thanks for your answer. Ok, but from the fmriprep doc ( Running fMRIPrep via Docker containers — fmriprep version documentation ) it seems that :

$ fmriprep-docker /path/to/data/dir /path/to/output/dir participant
RUNNING: docker run --rm -it -v /path/to/data/dir:/data:ro
-v /path/to_output/dir:/out poldracklab/fmriprep:1.0.0
/data /out participant

the first arg should be the data dir (and my collegue has already been using this in the past) so I doubt that is the porblem

Hi @AlanTuring,

sourcedata is not where raw BIDS nifti files go, it’s where dicoms go. The input to fmriprep is the BIDS root directory.