FMRIPREP autorecon31 error


#1

Hello,
I’m processing some data with FMRIPREP v 1.0.3 and have hit an error for a subset of the subjects. I’ve pasted the start of the error log below and saved a sample report here: https://www.dropbox.com/s/5xtpamkugfe5xhq/example.pdf?dl=0. I believe that there is an issue with one of the Freesurfer steps, but I’m not quite sure where to begin in debugging the issue since I have no experience with Freesurfer prior to using FMRIPREP (and I’m still relatively new to the latter). Processing completes without any errors when I turn Freesurfer off for the affected subjects. I cannot find anything obviously different in the anatomical images for participants with vs. without errors. Do you have any suggestions for figuring out the source of the error? Thanks very much for your help.

Errors

Node Name: _autorecon31
File: /gpfs/group/sjw42/default/ASH/SEMA/bids/derivatives/fmriprep/sub-26/log/20180424-084930_27e350c7-5fd3-4552-a5cb-2d78b1ad2590/crash-20180424-212239-sjw42-_autorecon31-8d8ff00d-1573-4122-b586-85fe13cf0b50.txt
Working Directory: /gpfs/group/sjw42/default/ASH/SEMA/work/fmriprep_wf/single_subject_26_wf/anat_preproc_wf/surface_recon_wf/autorecon_resume_wf/autorecon3/mapflow/_autorecon31

#2

Hi Steve,

Unfortunately, those three lines don’t give any hint to the error. Are you able to post more of the error?

Also, you can try sharing the following file:

gpfs/group/sjw42/default/ASH/SEMA/bids/derivatives/freesurfer/sub-26/scripts/recon-all.log

This file may help discover the failure.


#3

@effigies - there seems to be more info in the report attached to the original issue, although it has been clipped due to conversion to PDF.


#4

Ah, I did not catch that.

@Steve_Wilson could you verify that /gpfs/group/sjw42/default/ASH/SEMA/bids/derivatives/freesurfer/sub-26/mri/wmparc.mgz exists?

Also, from your paths, I’m guessing you’re using Singularity… are you using --cleanenv? If you have FreeSurfer 5.3 in your path, you may be calling an incompatible version of FreeSurfer. If you would like to use FreeSurfer 5.3 instead, I would recommend pre-running it (see the documentation for details).


#5

Thanks for the quick replies. And sorry for not noticing that the report got clipped. I tried uploading the html file itself but wasn’t able to expand the error link, so I copied and pasted the text here: https://www.dropbox.com/s/yd576eali2d4m50/Errors.txt?dl=0

@effigies - I’m actually running using a manually prepared environment w/freesurfer 6.0.1; unfortunately, our HPC currently isn’t set up to allow Docker or Singularity containers. I have confirmed that the wmparc.mgz exists for the subjects with errors. The environment set up works for most subjects - it’s just a small number that have caused problems. Thanks for the pointer about pre-running freesurfer.


#6

This looks like it may be a problem with your FreeSurfer installation. It’s looking for the following file:

/gpfs/group/sjw42/default/sjw42_collab/sw/freesurfer-20170118/sources.sh

I would try running FreeSurfer yourself, through whatever submission pipeline you’re currently running fMRIPrep, to try to keep the environment as consistent as possible. If you don’t get the same error, it may be our problem, but it will be very difficult to debug your cluster’s FreeSurfer setup.

This may be preaching to the choir, but I strongly recommend contacting your HPC operators and trying to persuade them to install Singularity. It’s designed by HPC operators specifically to resolve all of the concerns they had with running Docker.


#7

Many thanks - hopefully I can convince our center to install Singularity (I believe they were looking into it). In the meantime, thanks for the suggestion and feedback.


#8

This might help when approaching your center IT management: https://singularity.lbl.gov/install-request


#9

Thanks for sharing the great resource, Chris.


#10

Just wanted to post a quick update that this issue was caused by reference to an inactive version of freesurfer in my .bashrc file; removing this took care of the problem. Many thanks for all the help.