Fmriprep compatibility with old version of Singularity

Hi all,

Just want to ask is there a version of fmriprep that is still compatible with Singularity 2.4.6? I tried running the latest version of fmriprep (1.5.6) but encountered an error of ‘Unknown image type’, I also tried some older versions fmriprep (1.0.11) and got the same error.


I know that this isn’t the answer that you want, but there are some fairly significant security issues with 2.4.6, and minimally you (or a sysadmin) should consider upgrading to 2.5.1. Better yet, update to some 3.x version to likely fix this error too :slight_smile:

Thanks for the reply. I am considering to update Singularity to 3.x version as well.

fMRIPrep doesn’t currently distribute Singularity images. What is your source?

because my current version of singularity is below 2.5, I built the image using docker2singularity

Ah. If you’re using the latest docker2singularity, then you probably want to try using a different version:

As suggested by @vsoch, I am thinking about updating my Singularity to 3.x version. This seems easier than using docker2singularity to build the image

1 Like