Fmriprep - correct usage for --skip-vols-num

Hi - Sorry for the very simple question, but what is the correct format for using the newly added --skip-vols-num option in fmriprep? I tried adding ‘–skip-vols-num 4’ to my call but it didn’t seem to work, unless I had an issue somewhere else that I missed.

That does look like the correct usage, do you mind giving:

  1. how you’re using fmriprep (bare install, fmriprep-docker command line tool, docker or singularity)?
  2. the exact command you used
  3. the error message you received

Forgot the parameter was renamed to --dummy-scans, so use --dummy-scans 4 instead.

I’m using singularity with the following command:

fmriprep --participant_label 107 --nthreads 8 --verbose --skip-bids-validation --longitudinal --skip-vols-num 4 --output-spaces MNI152NLin6Asym:res-2 MNI152NLin2009cAsym:native T1w --fs-license-file /gpfs/group/sjw42/default/sjw42_collab/sw/freesurfer-6.0.1/license.txt --work /gpfs/group/sjw42/default/ASH/DVAL/work /gpfs/group/sjw42/default/ASH/DVAL/bids /gpfs/group/sjw42/default/ASH/DVAL/bids/derivatives participant

I’ve pasted the error below. It appears that command isn’t being parsed correctly. It’s probably a silly mistake on my part, but I can’t seem to locate it (e.g., doesn’t seem to be a mistyped path).

usage: fmriprep [-h] [–version] [–skip_bids_validation]
[-t TASK_ID] [–echo-idx ECHO_IDX] [–nthreads NTHREADS]
[–omp-nthreads OMP_NTHREADS] [–mem_mb MEM_MB] [–low-mem]
[–use-plugin USE_PLUGIN] [–anat-only] [–boilerplate]
[–ignore-aroma-denoising-errors] [–error-on-aroma-warnings]
[-v] [–debug]
[–ignore {fieldmaps,slicetiming,sbref} [{fieldmaps,slicetiming,sbref} …]]
[–longitudinal] [–t2s-coreg]
[–output-spaces OUTPUT_SPACES [OUTPUT_SPACES …]]
[–output-space {T1w,template,fsnative,fsaverage,fsaverage6,fsaverage5} [{T1w,template,fsnative,fsaverage,fsaverage6,fsaverage5} …]]
[–template {MNI152NLin2009cAsym}]
[–template-resampling-grid TEMPLATE_RESAMPLING_GRID]
[–bold2t1w-dof {6,9,12}] [–force-bbr] [–force-no-bbr]
[–medial-surface-nan] [–dummy-scans DUMMY_SCANS]
[–aroma-melodic-dimensionality AROMA_MELODIC_DIMENSIONALITY]
[–fd-spike-threshold FD_SPIKE_THRESHOLD]
[–dvars-spike-threshold DVARS_SPIKE_THRESHOLD]
[–skull-strip-template {OASIS30ANTs,NKI,MNI152NLin2009cAsym}]
[–skull-strip-fixed-seed] [–fmap-bspline] [–fmap-no-demean]
[–use-syn-sdc] [–force-syn] [–fs-license-file PATH]
[–no-submm-recon] [–cifti-output | --fs-no-reconall]
[-w WORK_DIR] [–resource-monitor] [–reports-only]
[–run-uuid RUN_UUID] [–write-graph] [–stop-on-first-crash]
[–notrack] [–sloppy]
bids_dir output_dir {participant}
fmriprep: error: argument analysis_level: invalid choice: ‘/gpfs/group/sjw42/default/ASH/DVAL/bids/derivatives’ (choose from ‘participant’)

I’ve edited my post above, but I believe switching out --skip-vols-num for --dummy-scans should fix the problem you are experiencing.

Thanks! That did it. I should have caught that in the list of options :slight_smile: