fMRIPrep crash due to T1w.json & task-rest_bold.json missing while using valid BIDS dataset

Summary of what happened:


I am trying to run fMRIPrep on this datasets ds004513.

Command used (and if a helper script was used, a link to the helper script or the command generated):

fmriprep \
    ~/ds004513 \
    ~/fmriprep-output \
    participant \
    --work-dir ~/workdir \
    --participant-label s003 \
    --nthreads 32 \
    --omp-nthreads 32


Environment (Docker, Singularity, custom installation):

Data formatted according to a validatable standard? Please provide the output of the validator:

Relevant log outputs (up to 20 lines):

I get this error

cp: cannot stat '~/ds004513/T1w.json': No such file or directory
cp: cannot stat '~/ds004513/task-rest_bold.json': No such file or directory

Screenshots / relevant information:

I tried to find similar issue, but was unsuccessful.
Any ideas would be greatly appreciated!


Hi @mathdugre,

I have labeled your post as Software Support and added in the Software Support post template. For future related software issues please use this category. To make it easier to help you, please edit your post to include some additional information (fmriprep version, how you are running it, BIDS validation etc.).

Is this the only thing that is reported? Because this seems like something from a helper script before fMRIPrep begins.


Hi @Steven ,

I am indeed using a helper script. I tried running fMRIPrep without my helper script and it seems to be running now.
After changing dataset, I started getting this error and mistakenly assumed it was due to the interaction between fMRIPrep and the dataset.
Thank you for your insight and sorry for the bother.

I was unware of the different categories system. I will make sure to use it in the future.

Thanks again,

All good, happy that it appears to be running now!