fMRIPrep-docker command

I am having the same issue.

saim@logan:~/.local/bin$ ls
fmriprep-docker

fmriprep is loaded on here.

I am able to run the docker hello-world command right after I have downloaded docker, but afterwards, I have to run sudo docker hello-world. This is the error message I am getting:

image

I have ran PATH="$PATH:$HOME/.local/bin" that @effigies suggested, but it is still providing the same error message.

It looks like your user doesn’t have permissions to run Docker. Have you gone through Post-installation steps for Linux | Docker Documentation?

It worked! Thank you so much @effigies

Could you tell me how to run docker image on Linux Ubuntu system? I can not find proper instruction for Linux in this topic (for Mac and Windows it here OSF | BrainsCAN Computational Core Neuroimaging Wiki Wiki). Thanks for reply.

I were trying to run this command :

That is an error from the BIDS validator. If your dataset does not validate, fMRIPrep is reasonably likely to error in a confusing way. If you don’t care and want to try to run on an invalid dataset, you can pass --skip-bids-validation.

when I use
find ~/.local -name fmriprep-docker
it says :–
FIND: Parameter format not correct

@Vineet_Dhokare It would probably be best to start from the beginning. What operating system are you on? How did you install fmriprep-docker?

I am on windows 10

I have docker installed as per instruction on the official website.

I entered this command in the command prompt as admin :
pip install --user --upgrade fmriprep-docker

Hey everyone,

I have a similar question.

Like others, I am also new to Docker and fMRIprep-docker. So far, I’ve reached this stage (please see image attached):

Do I need to change the path where fmriprep-docker is and where do I add it? I have Python and Anaconda installed. Do I have to change the path to Python or Anaconda or both?

Thank you for your help.

Best,

Rubina

If you can’t use fmriprep-docker directly, you can try python -m fmriprep_docker.

Hi @effigies

Thank you for your reply.

I changed the path to Anaconda and it worked.

Best,

Rubina

Hi @effigies,

I have a new question which is related to fMRIPrep-docker command but it is on Ubuntu. I hope this a related thread in which I can post my query (I looked at other websites but couldn’t find an answer to this question).

I decided to use Ubuntu because WSL 2 integration is enabled via Ubuntu. I installed fmriprep command but I am having trouble understanding the fmriprep-docker usage command which is as follows:

usage: fmriprep-docker [-h] [–version] [-i IMG] [-w WORK_DIR] [–output-spaces [OUTPUT_SPACES [OUTPUT_SPACES …]]]
[–fs-license-file PATH] [–fs-subjects-dir PATH] [–config-file PATH]
[–anat-derivatives PATH] [–use-plugin PATH] [–bids-database-dir PATH]
[–patch PACKAGE=PATH [PACKAGE=PATH …]] [–shell] [–config PATH] [-e ENV_VAR value]
[-u USER] [–network NETWORK] [–no-tty]
[bids_dir] [output_dir] [{participant}]

(Note:I have both anatomical and functional Nifty images)

I started writing a script but I’m stuck with the remaining lines.

Here it is:

I would greatly appreciate and welcome any suggestions you may or if you could refer me to a website that answers this question.

Thank you,

Rubina

Hi @Rubina,

The command is intended to be used like a normal fmriprep command, which will translate to the correct Docker invocation. So you want something like:

fmriprep-docker C:\Users\rubin\BIDS C:\Users\rubin\derivatives participant \
    --fs-license-file C:\Users\rubin\derivatives\freesurfer\license.txt \
    --participant-label C0120061

Hi @effigies,

Thank you for your quick reply but I get this response:

This seems to be a WSL issue in converting paths from Windows style to Unix style. I’m not sure what the corrected paths should be. Possibly:

fmriprep-docker /home/rubina/BIDS /home/rubina/derivatives participant \
    --fs-license-file /home/rubina/derivatives/freesurfer/license.txt \
    --participant-label C0120061

I tried that code but it didn’t work. However, after extensive research, I realised I have to create a symbolic link.I downloaded Link Shell extension. What I don’t know is whether the symbolic link is created where the license file is and fmriprep-docker is (or where Python is)?

Would you know about this?

A symbolic link acts the same as a typical shortcut, so as long as your shell can find the symlink, and that link points to the license alright, it will work. However, if your shell can’t parse the path correctly due to differences in Unix and Windows notation, as suggested earlier, your problem will still likely persist, since the shell won’t be able to find the symlink either.

So I think I know what where the problem was and I was missing -v in front of the code because I have WSL 2 installed however, I run into another problem…I accidentally deleted niprep/fmriprep image from images in Docker…is there anyway of downloading it again?

Many thanks for your help.

In the picture you posted it looks like the container was downloading. Is it still running or did you stop the program?

It was running but I get this message and it stops here:

image

MANAGED BY INCF