Fmriprep / Docker: Error in DerivT1w_MNI_affine

Hi everyone,

I’m trying to use fmriprep via docker for a standard fMRI task-based dataset in BIDS format. When I run the pipeline for the first subject of this dataset, with the ANTs skull stripping turned off, I stumble upon the following error (see below).

As I’m new to fmriprep, and also relatively new to Nipype, I don’t know what to make of it or how to fix it.

Maybe you can help me. Also, I’m not sure whether neurostars actually is the right place to address this issue or whether I should turn directly to the fmriprep github page?


Error Message:

Node Name: workflow_enumerator.01.t1w_preprocessing.DerivT1w_MNI_affine

Working Directory: /root/src/fmriprep/work/workflow_enumerator/01/t1w_preprocessing/DerivT1w_MNI_affine

base_directory: /outputs
ignore_exception: False
source_file: /bids_dataset/sub-01/anat/sub-01_T1w.nii
suffix: target-MNI152NLin2009cAsym_affine

Traceback (most recent call last):
File “/usr/local/miniconda/lib/python3.5/site-packages/nipype/pipeline/plugins/”, line 52, in run_node
result[‘result’] =
File “/usr/local/miniconda/lib/python3.5/site-packages/nipype/pipeline/engine/”, line 366, in run
File “/usr/local/miniconda/lib/python3.5/site-packages/nipype/pipeline/engine/”, line 476, in _run_interface
self._result = self._run_command(execute)
File “/usr/local/miniconda/lib/python3.5/site-packages/nipype/pipeline/engine/”, line 607, in _run_command
result =
File “/usr/local/miniconda/lib/python3.5/site-packages/nipype/interfaces/”, line 1068, in run
File “/usr/local/miniconda/lib/python3.5/site-packages/nipype/interfaces/”, line 973, in _check_mandatory_inputs
raise ValueError(msg)
ValueError: DerivativesDataSink requires a value for input ‘in_file’. For a list of required inputs, see

This looks like a bug, so it might be good to open a GitHub issue, but Neurostars is a valid place to ask questions.

It looks like you’re running the fmriprep BIDS App? Can you give the full command you used? And the version (pass the -v flag.)

1 Like


Thanks for helping me out.

Yes, I am running the BIDS App, with the following from command line:

docker run -ti --rm -v /my_data_dir:/bids_dataset:ro -v /my_out_dir:/outputs bids/fmriprep /bids_dataset /outputs participant --participant_label 03 --no-skull-strip-ants

When I request the version, by adding the -v flag, I get:

fmriprep vdev

Hi @_rmin, to clarify, was your issue resolved here? Or is this unrelated?

(We’re running tests on a more recent version now. I was waiting for them to finish, and then we would update the Docker image and ask you to try re-running with the new image.)

Hi, yes, both issues were due to insufficient RAM-allocation for the fmriprep BIDS-app in Docker.

Thanks so much for your help!