Fmriprep error while creating initial workflows

neuroimaging
fmriprep

#1

I’m using fmriprep with a Docker container and have preprocessed several test datasets. Today I ran the command as I always have and encountered an error almost immediately after the command started running, while fmriprep is creating the initial workflows, etc. Here is my command and error message:

$ sudo docker run -ti --rm -v /path/to/data:/data:ro -v /path/to/output/folder:/out poldracklab/fmriprep:latest /data /out/out participant --no-freesurfer --low-mem
Unable to find image ‘poldracklab/fmriprep:latest’ locally
latest: Pulling from poldracklab/fmriprep
b3e1c725a85f: Pull complete
4daad8bdde31: Pull complete
63fe8c0068a8: Pull complete
4a70713c436f: Pull complete
bd842a2105a8: Pull complete
67664e735a30: Pull complete
7f609af92f3a: Pull complete
8bc3b5e35655: Pull complete
a3ed95caeb02: Pull complete
41d3c0a77b84: Pull complete
ed664ade80e8: Pull complete
d4531e07e474: Pull complete
3b22a68cc1bd: Pull complete
a09ba74f0994: Pull complete
61bdcbbfa00e: Pull complete
5f762b942990: Pull complete
212abf9e62c2: Pull complete
a5bda98def3c: Pull complete
ea36e1d961b4: Pull complete
8d1b10bcaef9: Pull complete
8ff4009a2343: Pull complete
21f94d0710ca: Pull complete
10d8eb98c470: Pull complete
1a20a7d34950: Pull complete
b4a3fdd53c86: Pull complete
88a5bfc04f56: Pull complete
6a50eb488f45: Pull complete
56a98373198c: Pull complete
399dd80b26b2: Pull complete
Digest: sha256:c9c2a5bbb4350275bcf33777c014aa89724372892618cc5128fc7187b30d68e6
Status: Downloaded newer image for poldracklab/fmriprep:latest
171031-22:19:59,825 cli INFO:

Running fMRIPREP version 0.6.8:

  • Participant list: [‘01’, ‘02’, ‘03’, ‘04’, ‘05’, ‘06’, ‘07’, ‘08’, ‘09’, ‘10’].
  • Run identifier: 20171031-221959_b4ecc041-6f9b-412c-87c1-296d7ed29263.

Traceback (most recent call last):
File “/usr/local/miniconda/bin/fmriprep”, line 11, in
load_entry_point(‘fmriprep==0.6.8’, ‘console_scripts’, ‘fmriprep’)()
File “/usr/local/miniconda/lib/python3.6/site-packages/fmriprep/cli/run.py”, line 214, in main
create_workflow(opts)
File “/usr/local/miniconda/lib/python3.6/site-packages/fmriprep/cli/run.py”, line 326, in create_workflow
ignore_aroma_err=opts.ignore_aroma_denoising_errors,
File “/usr/local/miniconda/lib/python3.6/site-packages/fmriprep/workflows/base.py”, line 189, in init_fmriprep_wf
ignore_aroma_err=ignore_aroma_err)
File “/usr/local/miniconda/lib/python3.6/site-packages/fmriprep/workflows/base.py”, line 430, in init_single_subject_wf
ignore_aroma_err=ignore_aroma_err)
File “/usr/local/miniconda/lib/python3.6/site-packages/fmriprep/workflows/bold.py”, line 261, in init_func_preproc_wf
run_stc = (“SliceTiming” in metadata and
TypeError: argument of type ‘NoneType’ is not iterable

The ‘Unable to find image ‘poldracklab/fmriprep:latest’ locally’ was probably because I changed some of my Docker settings, which can delete old images. But I reset all of the settings on my Docker build (back to what I had successfully used many times) and still got the same error. If anyone thinks it might be a Docker-specific problem, here is my info:

$ sudo docker info
Containers: 0
Running: 0
Paused: 0
Stopped: 0
Images: 1
Server Version: 17.09.0-ce
Storage Driver: aufs
Root Dir: /var/lib/docker/aufs
Backing Filesystem: extfs
Dirs: 48
Dirperm1 Supported: false
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
Volume: local
Network: bridge host macvlan null overlay
Log: awslogs fluentd gcplogs gelf journald json-file logentries splunk syslog
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: 06b9cb35161009dcb7123345749fef02f7cea8e0
runc version: 3f2f8b84a77f73d38244dd690525642a72156c64
init version: 949e6fa
Security Options:
apparmor
Kernel Version: 3.13.0-135-generic
Operating System: Ubuntu 14.04.5 LTS
OSType: linux
Architecture: x86_64
CPUs: 8
Total Memory: 31.3GiB
Name: mufasa
ID: QIV3:PXTV:W32X:A4DH:NO6R:CES3:FIEL:EGHH:W5UM:L6JT:7RZS:W77G
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
Experimental: false
Insecure Registries:
127.0.0.0/8
Live Restore Enabled: false

Any insight would be greatly appreciated!


#2

What is the content of the JSON sidecar for a bold run (any of them)?


#3

Is your dataset passing the validator: https://github.com/INCF/bids-validator ?


#4

Thanks for your response and sorry for getting back to you late. My data was all fine but my *task_bold.json files weren’t formatted correctly. Fixing those did it. Thanks for your help.