Fmriprep: fieldmap present but ignored

fmriprep

#1

Hi,

I tried out fmriprep on a single subject’s dataset (using singularity, version 1.0.0-rc8), and it gave me the following warning for each functional run:
“workflow WARNING: No fieldmaps found or they were ignored, building base workflow for dataset”

I have fieldmap (phasediff, magnitude1 and magnitude2) and the dataset passed the BIDS validator (using the online version, fieldmap was explicitly listed there as an available modality). Any ideas what might have gone wrong? I am new to BIDS and fmriprep, so it might be something trivial…

I uploaded the fieldmaps (in sub-sid000522/fmap/), the fmriprep output log and the html report here:
https://drive.google.com/open?id=1ulisw2BEebaHAn-ax2udrmZumPT2mPZ-

Apart from this issue, fmriprep worked as expected. This tool is great, thanks to all its developers / contributors!

best,
adam


Ambiguity in fieldmap description in Bids Spec
#2

Hi,

You need to specify “IntendedFor” field in the _phasediff.json files to point which scans the estimated fieldmap should be applied to.

In the future FMRIPREP might switch to applying fieldmaps to all runs if the IntendedFor field is missing. See discussion at https://github.com/poldracklab/fmriprep/issues/783#issuecomment-338341237


#3

More on the “IntendedFor” field can be found in section 8.9 of the spec. You should also use the validator to check if the field is specified correctly.


#4

Thank you for the quick reply, it is running fine now