Fmriprep: fieldmap skull stripping problem?

fieldmap
fmriprep
#1

Dear fmriprep community,

Thank you for such a useful tool, I have been able to process a dataset when not using fieldmaps but now that I have added them in, I am not getting good results when performing susceptibility distortion correction:

I wonder if perhaps this is occurring because of a problem with of unsuccessful skullstripping of the field maps?

I have uploaded the report at: https://www.dropbox.com/sh/1sft25p9rbkvouo/AADVQjfCPMRtkzzXbxBVlg08a?dl=0

Many thanks for any suggestions

Rob

#2

Increasing the BET threshold does seem to improve the skullstripping. Is there anyway to implement this in fmriprep, or should I strip the magnitude image (and mask the fieldmap) outside of fmriprep?

#3

Hi @rob, this looks like sdcflows issue #23, and I’d encourage you to follow up there.

For context, we’ve begun splitting out various components of fMRIPrep into their own packages to keep the scopes more well defined. This should make it easier for users to find the place to fix bugs (assuming they know about the different packages…) and enable testing of the different components in isolation from each other. e.g., If you modify the BET threshold, it would be good to run on many magnitude images to make sure that we aren’t now setting it too high for images that were being correctly stripped before.