Fmriprep hanging at executing "_thresholdXX"

Summary of what happened:


I’m a beginner with fmriprep…
I’m running the pipeline for 8 subjects in parellel.
I previously ran into a lot of issues that were solved (due to lack of resources mostly).
Now it’s been 18 hours that all my subject are stuck after the step

[Node] Setting-up "_threshold80" in "/tmp/work/fmriprep_22_1_wf/single_subject_001_wf/func_preproc_ses_01_task_rest_inscapes_bkwd_run_01_wf/bold_t1_trans_wf/threshold/mapflow/_threshold80".

either executing the last threshold or having finished the last threshold i.e :

[Node] Finished "_threshold87", elapsed time 0.038143s.


[Node] Executing "_threshold80" <fmriprep.interfaces.maths.Clip>

(different threshold number for each subject)

Command used (and if a helper script was used, a link to the helper script or the command generated):

fmriprep-docker $bids_root_dir $bids_root_dir/derivatives \
    participant \
    --participant-label $participant \
    --skip-bids-validation \
    --md-only-boilerplate \
    --fs-license-file /home/martin/fs-license.txt \
    --output-spaces MNI152NLin2009cAsym:res-2 \
    --nthreads $nthreads \
    --use-aroma \



Environment (Docker, Singularity, custom installation):


Data formatted according to a validatable standard? Please provide the output of the validator:


Relevant log outputs (up to 20 lines):

Screenshots / relevant information:

For each subject I have two longitudinal sessions each with anat and func data, I wonder if the problem can be caused by this and be solved by addind --longitudinal ?

Any insight would be much appreciated,
Thank you

Hi @Martin_Breyton and welcome to neurostars!

I have relabeled your issue as software support and added the corresponding template, please edit your post to add the missing info so we can best address your issue.


@Martin_Breyton how much memory and cpus are you giving fMRIPrep?

I am not limiting my memory in docker or fmriprep. I have 512GB of mem and 16 CPUS, each subject running on 2 threads.
I have restarted everything and it’s working for now…
I didn’t change anything it’s very bizarre !