fMRIprep installation

fmriprep
#1

Hello everyone, I would appreciate any suggestions that could help solve this issue (please see attached). I have been trying to install fmriprep-docker on my iMac (macOS High Sierra; v 10.13.6). I also tried on a macbook (macOS Mojave) and got exactly the same error.

I have used the following commands with and without “–user” as suggested elsewhere.

$ pip install --user --upgrade fmriprep-docker
$ sudo pip install --user --upgrade fmriprep-docker

Is there anything I am doing wrong? Please help. Thank you.

#2

Hi, you may need to upgrade pip. python -m pip install --upgrade pip

#3

Thanks @effigies ! I upgraded pip but still getting the same error message.

#4

It looks like you have a couple different versions of Python going on. When you did python -m pip install --upgrade pip, it installed with Python 2; when you did sudo pip install ..., it attempted to install with Python 3. The simplest way to make sure that you’re putting things in the same place is to consistently use python -m pip instead of just pip, and use either sudo or --user or neither, but not both.

So:

python -m pip install --upgrade pip
python -m pip install --upgrade fmriprep-docker

or

python -m pip install --user --upgrade pip
python -m pip install --user --upgrade fmriprep-docker

or

sudo python -m pip install --upgrade pip
sudo python -m pip install --upgrade fmriprep-docker

The first may fail for lack of permissions, but the other two should work.

For simplicity, however, it may be best to ignore the built-in Python altogether and install an Anaconda distribution. This is very consistent across platforms.

#5

I installed Anaconda distribution as suggested and that miraculously solved the issue. I am now test-running fMRIPrep on one subject and everything looks fine so far.

Thanks @effigies for your support and kudos to you and the team for your contribution to science.

3 Likes