Fmriprep OSError: Duplicate node name "func_preproc_ses_post_wf" found

Summary of what happened:

I am getting fmriprep OSError: Duplicate node name “func_preproc_ses_post_wf” found. i have deleted all old files and changed derivates dir, still no fix. any tips would be helpful. I have run this code previously and it worked, so im not sure why it isnt now. thanks!

Command used (and if a helper script was used, a link to the helper script or the command generated):

singularity run --cleanenv -B /shared:/shared -B /work/cnelab/TECHS/MRI/BIDS:/data -B /scratch/tinney.e/fmriprep_jobs/.cache/templateflow:/templateflow -B /scratch/tinney.e/fmriprep_jobs:/work -B /work/cnelab/TECHS/MRI/BIDS/derivatives/freesurfer_7.2.0/post:/fsdir /shared/container_repository/fmriprep/23.0.2/fmriprep_23.0.2.sif /data /data//derivatives/fmriprep-23.0.2 participant --participant-label 03 -w /work/ -vv --omp-nthreads 8 --nthreads 12 --mem_mb 30000 --output-spaces MNI152NLin2009cAsym:res-2 anat fsnative fsaverage5 --use-aroma --fs-subjects-dir /fsdir --skip_bids_validation --bids-filter-file /data/filter-file.json



Environment (Docker, Singularity, custom installation):


Data formatted according to a validatable standard? Please provide the output of the validator:

Relevant log outputs (up to 20 lines):

Screenshots / relevant information:

Hi @ET_123456,

I have relabeled your post as Software Support and added in the usual support template. Please make posts under this category for future software related questions.

Did you make sure to use a fresh working directory?


Hi Steven,

yes, i created a fresh working directory for this as well as fresh derivates directory.


Please don’t use this. The issue is likely that you have both .nii and .nii.gz files, and this would be caught as an error by the BIDS validator.