fMRIPrep poor registration between functionals and anatomical

Hi NeuroStars,

We’re running fMRIPrep v1.4.1 on multiband, multiecho data and are running into poor registration issues between the functionals and anatomical for several subjects. We’re trying to troubleshoot this (test case is a subject with enlarged ventricles) and have a couple of questions:

  1. Which image is used for registration to the T1? Is it a temporary image?
  2. Is it possible to register the images manually, and then continue with the pipeline?

Thank you!
ali

@oesteban could you please advise on how to proceed for datasets showing poor registration between functionals and anatomicals?

Hi @alioco !

To answer your questions:

  1. It depends on how you called fMRIPrep. With the t2s_coreg flag, the calculated T2* map is used for coregistration. Otherwise, the appropriate “bold_ref_brain” is supplied here based on your exact call:

Of note, multi-echo does not currently take advantages of eg SBRef images, although there is an open niworflows PR from @tsalo to patch this. See: https://github.com/poldracklab/fmriprep/issues/1745

  1. I think that would be a complicated bit of workflow surgery, although it’s not technically impossible. I’m not the best person to advise on exactly how to achieve that, though.

I wanted to follow up with a few questions:

  1. Could you share your exact call of fMRIPrep ? What kinds of images are you supplying (i.e., do they have accompanying SBRefs) ?

  2. Could you share an example reporting showing poor coregistration ? It might help to see if it’s similar to that reported by @markushs in Fmriprep handling of multi-echo data with single-band reference scans.

Thanks !

Elizabeth

Thanks @emdupre

We actually tried running without the t2s_coreg flag and that seems to help.

Originally the original call was:
singularity exec --cleanenv
/beegfs/work/public/singularity/fmriprep-1.4.1.sif fmriprep ${BIDS_Dir} ${Out_Dir} participant
–fs-license-file /beegfs/work/hartley/projects/MotER/scripts/fsLicense/license.txt
–ignore slicetiming
–output-spaces “MNI152NLin2009cAsym” “T1w”
–participant_label ${SUBJ_ID}
–t2s-coreg

We are supplying the accompanying SBRef images for each echo. I have shared an example report with your gmail - please let me know if there’s anyone else that would be helpful to share this with.

Thanks!
ali

Thanks, @alioco !

It looks like these reports are the originals (i.e., with --t2s-coreg). Could you also share the more recent ones without that flag ?

Elizabeth

Of course, shared! let me know if you need anything else @emdupre !

ali

MANAGED BY INCF