Fmriprep. problem when added fieldmap to fmri task

Dear fMRIprep-makers,

Thank you for making such a super tool!

I used fmriprep:1.1.8 with an FMRI task and a fieldmap.

Things look wonky from the point of summarizing the SDC. See top part of this figure.

I then deleted the field map from the fmap folder and reran fmriprep and got some puzzling results figure - below, particularly z=18. In the version without the fieldmap, the carpet map was complete while the version with the fieldmap, there seemed to be missing data.

I want to use the fieldmap collected. Have others run into similar issues and if so how did they solve this?.

Cheers, Eunice

Could you share the full report (on the version with fieldmaps) with figures (they are in a separate folder)?

Did you run the bids validator on the input dataset?

BTW there is no need to delete fieldmaps if you don’t want to use them. You just need to pass --ignore fieldmaps

Thank you for replying so quickly.,

Apologies - I was on the road and could not address your request.

I reran again because I realized that we had 2 magnitude and 1 phasediff image.
These files were BIDs validated. The carpet map looks better but still the results are puzzling.

Output report is here.

Hi Chris, just a follow-up. A colleague suggested I try another head for the same task and interesting, we don’t have the same problems so it could be something to do with the data we initially tried fmriprep on. Check out:

I’m still curious as to why we had the problem we had with the first head if you have time. Cheers, Eunice

Seems like FMRIPREP is having issues regularizing the fieldmaps (the input data is not great - there are high intensities on the edge of the brain). It’s hard to see without the orgiginal HTML reports (and figures which are in a separate folder) since they include animations (stripped after you converted them to PDF).

It would be interesting to see the data if you can share them.

You can also try rerunning with --use-syn-sdc --force-syn flags to ignore existing fieldmaps and perform the correction using fieldmapless approach.

In the end its always how good the data is going in that has a big effect on what comes out! I tried to upload the data and output folder for this but I think they were too large.

However I was able to upload the html and figures. Am not sure if this is helpful:

I did run it without fieldmaps in one of the many versions of this. Popped this in the folder.

One thing that might be worth checking is EffectiveEchoSpacing - consult your MR personnel and make sure you use the right units. See

PS If you skip fieldmaps and do not use --use-syn-sdc --force-syn flags no susceptibility correction will be performed.

Dear Chris, Thank you again. Checked the EffectiveEchoSpacing and had folk look at my problem. Is there any chance that I can backchannel you this head to work out what is wrong.

Dear Chris, Good news!

In a last ditch effort, I asked a matey over here – David Smith – to look at my BIDs setup and the numbers were the same, he suggested that I use HeuDiConv to put the DICOM into BIDs format. I had originally put my data into BIDs over a year ago manually. David pointed me to your tutorial on HeuDiConv which helped a lot.

I noticed HeuDiConv added additional .json for the 2 magnitude field map files to what I had had and in all the .json files added a lot more information than I had had originally. And yippee! None of those weird smeary ‘ROIs in BOLD’ space output.

Check out.

Am hoping that this is helpful to someone else who may run into similar problems. Cheers, Eunice

1 Like

Thanks for sharing the solution Eunice. This is very helpful.