Fmriprep quits after a few minutes of running

Hi everyone,

I have been trying to run a single participant through fmriprep on sherlock, and it seems to be quitting after a few minutes of running with no obvious returned error messages.

Here is what I have been submitting in the task file:

singularity run ${fmriprep_img} ${SCRATCH}/MRI/BIDS/2019_RelAbsDisp ${SCRATCH}/MRI/OUT/2019_RelAbsDisp participant -w ${SCRATCH}/MRI/temp --participant_label 001 --output-spaces anat fsaverage5 --mem-mb 5000 --nthreads 10 -vv

and the fmriprep_img I have been using is


The messages I have been receiving in the .err file are as follows:

rm: cannot remove ‘/scratch/users/milenak/MRI/temp/*’: No such file or directory
Process Process-2:
Traceback (most recent call last):
File “/usr/local/miniconda/lib/python3.7/multiprocessing/”, line 297, in _bootstrap
File “/usr/local/miniconda/lib/python3.7/multiprocessing/”, line 99, in run
self._target(*self._args, **self._kwargs)
File “/usr/local/miniconda/lib/python3.7/site-packages/fmriprep/cli/”, line 608, in build_workflow
File “/usr/local/miniconda/lib/python3.7/site-packages/fmriprep/workflows/”, line 258, in init_fmriprep_wf
File “/usr/local/miniconda/lib/python3.7/site-packages/fmriprep/workflows/”, line 607, in init_single_subject_wf
File “/usr/local/miniconda/lib/python3.7/site-packages/fmriprep/workflows/bold/”, line 543, in init_func_preproc_wf
if ‘MNI152NLin2009cAsym’ in volume_std_spaces else next(iter(volume_std_spaces))

Does anybody have any ideas?
Thanks so much!!

Just checking in to say that I am having the same problem with different data set (although same lab, same command, similar protocol), also on the Stanford Sherlock HPC. #fmriprep

Please, follow up here:

For now, I think you’d work around this problem by adding the template to --output-spaces:

singularity run ${fmriprep_img} ${SCRATCH}/MRI/BIDS/2019_RelAbsDisp ${SCRATCH}/MRI/OUT/2019_RelAbsDisp participant -w ${SCRATCH}/MRI/temp --participant_label 001 --output-spaces MNI152NLin2009cAsym anat fsaverage5 --mem-mb 5000 --nthreads 10 -vv

FYI, @milenak and others. I ran it as suggested by @oesteban and it finished.

1 Like

Thank you both for your input, this has worked wonderfully :slight_smile:

1 Like