Fmriprep run it on singularity - does not find path - error 'input folder is a directory'

Hello everybody.

I face a problem using singularity running fmriprep (see pics & below) in HPC Centos. I ran below in the command line:

singularity shell -B /storage/users/ /usr/local/bin/fmriprep-20.2.6.simg \ /storage/users/jguesten/PHD/data/MEMTRAIN2 /storage/users/iliopoul/PHD/data/MEMTRAIN2/derivatives \ participant \ --participant-label ah88

I get the error:
Path does not exist: < /storage/users/jguesten/PHD/data/MEMTRAIN2>. (i.e. the input folder).

However, when I run the above code with “shell” instead of “run” to get into the virtual environm of the container, I can /cd to /storage/users etc. which shows me that these folders are mounted.

Does not make sense to me.

  1. When I tree the same idea in a shell script ("bash <script_name> see screenshot), I get an error that the “/storage/users/jguesten/PHD/data/MEMTRAIN2 is a directory”.

Any idea ? I struggle a lot to make it work. Thank you very much in advance :slight_smile:

!

Try binding -B /storage/users/jguesten/PHD/data/MEMTRAIN2.

Thanks a lot for your reply! I still get the same error :confused:

Why should it show a ‘is a directory’ error; it’s meant to be a directory anyway. Since I mount this path and with running ‘shell’ I can navigate, cd/ etc then it shouldn’t be a problem.

Is there any reason you would not have read/write permissions for these folders?

From what I understand (see pic. ) I have access.

However, I am not experienced in Linux, maybe I understand sth wrongly here?

By typing “id” I see that I belong to the ‘iknduser’ group. So I should be able to read and execute (see 2nd place/permissions).

Looking at the images you posted, can you confirm that /home/iliopoul is also bound to the container, as that contains your FS license?

Yes I see singularity has access, since iliopoul is my user (see pic).

What could be wrong? :confused:

Is there a reason why you are putting your derivatives in a separate BIDS directory than the original dataset (as indicated by the different “users” path)?

I read the data from another user and want to have the outputs them in my own user (iliopoul) folder.

I tried copying the data to my home directory and use the same folder for input and output path but still didnt work.

Since I give valid paths /existing folders it shouldn’t matter. That’s what I understand at least.

Since I get an error, I assume singularity works per se and loads the image but sth else comes up.

MANAGED BY INCF