fMRIPrep -s (session) flag not available

Hello, I’m running fMRIPrep on a 2-session dataset and want it to run only on my first session. I used “-s 01” to specify the first session but I got:
fmriprep: error: unrecognized arguments: -s 01

Although I see the -s flag in fMRIPrep documentation, in my terminal I don’t see it among other flags. Anyone knows why this is missing and how I can point to a specific session? I’m running version 21.0.1

Thanks for the help!

That flag is deprecated. The current arguments that are accepted may be found here: Usage Notes — fmriprep version documentation

If you want to only run a certain session, you can pass in a --bids-filter-file. See here for an example:

1 Like