Fmriprep (singularity 1.41.) no such file or directory, ~/derivatives/fmriprep/logs/CITATION.bib

Have been getting the following error and then fmriprep crashes for a few subjects:
FileNotFoundError: [Errno 2] No such file or directory: ‘~/derivatives/fmriprep/logs/CITATION.bib’
Even though that file exists and there have been several (50+) other successful runs without that error.

I’ve tried just re-running them but it’s been like 3 re-runs already and same error. Any help would be appreciated, Thanks!

I wouldn’t worry about it. It’s the last thing that’s done after fMRIPrep completes, so you shouldn’t consider the run to be unsuccessful unless an actual node fails to run. Using the --md-only-boilerplate will avoid running the same conversion at the end of every run.

okay will try that. The thing is that the html report isn’t generated as well. So adding that argument would solve that issue?

I suspect so. Please let me know if it does not.

You could try updating singularity. 1.41 is a pretty old release (I believe the most recent version is 3.6). Anecdotally, I have found that more recent singularity releases are better with mounting your drives (such as the ~ drive, which may explain the inconsistency in finding the .bib file). As a test, you can enter a singularity shell by running singularity shell -e /path/to/fmriprep.img and see if the .bib file is mounted. Usually, the ~ drive should be mounted by default. Does that all make sense?


oh my bad, I meant that I am using fmriprep 1.4.1 sif… my singularity version is 2.6.1