Freeview quit unexpectedly

After installing the Freesurfer software the program runs OK but when I’m trying to load a data, I encounter the error “freeview quit unexpectedly” and program crashes.

My device : macbook air m1 2020.

Do you have a Freesurfer license in your installation directory?

Yes. I downloaded the license from the email sent by Free Surfer and pasted it in the following path: /Applications/freesurfer
I’ve also downloaded and installed the latest version of xquartz before installing and executing freesurfer.

Can you open freeview in your terminal and then try loading the image? A crash message in your terminal may be informative.

Also, is the license file specifically named license.txt?

I ran the program from the terminal, but after the program crashed, nothing was shown in the terminal! Also, the license file that was emailed to me had no name and was only displayed with \ . Although when I rename the license to license.txt, there was no change.

Can you just run freeview in the terminal, rather than using the open command?

I noticed that I made a mistake in setting an environment which caused the program to crash. Since I don’t have much experience with the terminal and The Free Surfer’s documentation is a bit confusing for me, I ask you to guide me in this field, Steven.

The version I’ve download is 7.4.1.

I’ve create a directory for freesurfer with code below:

export FREESURFER_HOME=/Applications/freesurfer/7.4.1

and I could run the program perfectly. But every time I close the program (or terminate terminal) and try to reopen it, I cannot use freeview command (zsh: command not found: freeview) unless I use that code and make a directory again. Is there any solution for this or I should execute that code every time I want to open the program?

Did you follow the video guide? attachment:installFS_demo.mp4 of DownloadAndInstall - Free Surfer Wiki

If that doesn’t work, I’d recommend you just email the FreeSurfer tech support mailing list: FreeSurferSupport - Free Surfer Wiki

You can just add these lines to your appropriate profile/RC file, and they will be automatically re-executed upon opening terminal. I believe Macs are all using .zprofile these days.


I’m having the same problem now which is quite annoying. Did you manage to sort it out?

Hi @Kaya_an and welcome to neurostars!

What troubleshooting steps have you taken so far? And can you say more about your computing environment?


I am taking the same result with segmentation fault 11 at each time and changed the MacBook from M3pro to Air but the problem still goes on

Hi @Mcercan,

What version of freesurfer? What kind of file were you trying to load? What troubleshooting steps from this thread have you tried?


I downloaded the freesurver version 7.4.1
To upload the T1.mgz or one of my nii.gz files something happens and and error message comes as ‘segmentation fault: 11’

I’ve tried to copy the code written above. It worked in M3 pro at first but later, I couldn’t continue

Thank you

I’m having the same problem. Has anyone figure this out? I downloaded the 7.4.1 version and when I try to open the T1.mgz from the sample video, it shuts down.

I’m having the exact same issue as @Parham_Zargar.
I installed freesurfer following the video :
However, everytime i try to load volume from freeview, it quits instantly and leaves a message of error

Therefore, I tried to uninstall everything and reinstall freesurfer and freeview, but still it quits everytime i try to load volume. I tried to install the 7.4.1 version of freesurfer ; and I am using a MacBook Pro Ventura 13.6.4.
And when I try to load a file from the terminal, freeview still quits instantly. However, if i try to run freeview from the terminal it opens, but it’s every time that i try to open a file with it that it quits…
Thank you in advance for your help :slight_smile: