FSL No Output, No Error

Hi, I am trying to run FSL (for the first level analysis) on our cluster but my script produces no error, no output, and doesn’t fail. My design file seems to be alright, so I presume the problem is in my script.

After the cluster parameters, my script is:

module load FSL/6.0.4 

feat /labs/XXXX/XXXXX/EventGroup/MIDGroup/FSF_Files/MID_S1_R1_009.fsf

I tried chmod 755 and tried changing the version but didn’t help. Any suggestions?

You’ll need to identify the source of the problem. Perhaps, on an interactive terminal, you can check whether the module loads correctly and if you are able to execute FSL commands.

Next, it’s running feat interactively and check if it is a problem of misuse of the tool.

All of this is assuming that your settings for (SLURM?) are correct, and indeed the standard error is being redirected somewhere you know.

Otherwise, please make sure of where the standard error is being redirected and check that.

The answer is to add the line below after loading FSL,

module load FSL/6.0.4 

source ${FSLDIR}/etc/fslconf/fsl.sh

feat /labs/XXXX/XXXXX/EventGroup/MIDGroup/FSF_Files/MID_S1_R1_009.fsf