FSL Post Install Stuck at 'Stage 2'

Hi all,

We just acquired a new Linux system in our lab (Ubuntu 20.04.1) and I am in the process of adding several programs, including FSL. I’m using Python2.7 to run the FSLinstaller.py script included on the fsl website through the terminal, and it seems to run fine.

>> FSL software installed.

However, following this, the script begins performing some “post install tasks”, which consist of at least two stages. Stage 1 achieves 100% status, but Stage 2 starts and sits at 0% continuously. I haven’t had this issue in the past. I am not getting any error messages and I’m having trouble finding any documentation on what is supposed to be happening. My next step is to dive into the python script to answer those last two questions, but I’m wondering if anyone else has experienced similar issues and how they may have solved them.

Of course, if there’s any system information that’s helpful to know and that I may have forgotten, please don’t hesitate to ask! Thanks in advance.

1 Like

I have the same question. Have you solved that?

Hi @wjpmitchell3 and @Czh0216,

I experience this same delay every time I install FSL via the FSLinstaller.py (directly on Ubuntu 20.04, 18.04, in Docker or Singularity image builds, etc.). This step includes downloading a lot of data that is used for the FSL suite, so it is limited by the speeds of your own network downloads and by the bandwidth of the network hosting that data.

One option to pursue if you want a more informative install would be to request the addition of some kind of download progress bar to the installer script (if this is not an existing non-default option).


1 Like

You’re absolutely right. I had assumed, I would see that 0% update as more data came in, but I left it run overnight and by the morning it had completed. I couldn’t see any evidence that it was actually running, but seems it was. A progress bar would be a big improvement. Thanks for the insight!

1 Like

Same problem. Is this new?

I don’t remember having run into it in the past, but like Paul suggested, it does resolve itself with enough time.

1 Like

I had the same issue last. It is due to the installation (fetching) of the python SAT package.

You can find my Docker file here:

I found the solution by reading the following stackoverflow post:

Here is my note:

The installation gets stuck on stage2,
due to some issue when fetching the SAT python package.

This is documented in:

The solution is:

  • Download the fsl-6.0.5-centos7_64.tar.gz.
  • Extract the *.yml that defines the python env.
  • Switch the order of the channels (as describe on the stackoverflow solution).
  • Replace the *.yml file by the new one in the tar file.
  • Run the installer with the new fsl-6.0.5-centos7_64.tar.gz.

Hope it will help.

1 Like