Getting subcortical data from fMRIPrep into fsLR 32k

I am aiming to combine some fsLR 32k surfaces I made from fmriprep outputs using this surface pipeline and these post-processing pipelines (anat space & MNI space) with subcortical data in MNI152NLin6Asym space (also postprocessed from fmriprep outputs).

This first step, I believe, is to grab just the subcortical data from the MNI outputs I have using the following command:

wb_command -cifti-create-dense-from-template \
91282_Greyordinates.dscalar.nii \
sub-MWMH317_ses-1_task-rest_space-fsLR_desc-subcort_bold.dscalar.nii \
-volume-all sub-MWMH317_ses-1_task-rest_space-MNI152NLin6Asym_desc-postproc_bold.nii.gz

When I run this command, however, I get the following error:

“ERROR: -volume-all specifies a volume file that doesn’t match the volume space of the template cifti file”

I looked into the nifti headers, and tried viewing the images, and it looks like while sub-MWMH317_ses-1_task-rest_space-MNI152NLin6Asym_desc-postproc_bold.nii.gz is in MNI152NLin6Asym space:

wb_view sub-MWMH317_ses-1_task-rest_space-MNI152NLin6Asym_desc-preproc_bold.nii.gz \

The images do not have the same dimensions:

I also double checked that tpl-MNI152NLin6Asym_res-02_T1w.nii.gz and 91282_Greyordinates.dscalar.nii are in the same space (via viewing) and have the same dimensions (via fslhd), and they do.

So I think the problem is that the fmriprep output has gotten rid of some voxels around the brain. Does anyone have suggestions for how I could address this issue? My first instinct is that I could add padding to match the fmriprep output to the MNI152NLin6Asym space, but I am not sure how to do this, and I am not sure if it is the best path forward.

If you do not specify the output resolution in the fmriprep command, the MNI output dimensions are based on the original images dimensions with some type of cropping. You can either resample the preprocessed MNI152NLin6Asym images with something like 3dresample from afni or run fmriprep again while setting the resolution in the output spaces. Setting the resolution changes the output-spaces option to something like this: --output-spaces MNI152NLin6Asym:res-2. There is more information here if you want to read more: Defining standard and nonstandard spaces where data will be resampled — fmriprep version documentation