How to upload EEG data


#1

Hello,

I am trying to upload a dataset comprising EEG and fMRI data simultaneously acquired but I am experiencing a number of problems and I was hoping to get some assistance from you.

Basically I am not sure how to upload the EEG data in a BIDS compatible format and the first approach I tried was to use a nameless .bidsignore file in the subject specific folder.

This is what I wrote in the .bidsignore file

{
“ignore”: [],
“warn”: [],
“error”: [],
“ignoredFiles”: ["/EEG/**"]
}

As all the EEG data were in the folder called “EEG” in the subject specific folder. However the EEG data files are not ignored and give an error as they are not BIDS compatible.

On another note, the file README.txt in the root folder is also not recognised with the same error message.

can you help me with this?


#2

Hi,

The .bidsignore file takes the same syntax as .gitignore or .dockerignore files. You can learn about it here.

The file should be placed in the root of the dataset folder (the same level as sub- folders are). In your case, the syntax should be

/sub-*/EEG

I would also encourage you to look at the BIDS EEG draft extension and follow it if possible. It is not part of BIDS yet (so it’s not supported by the validator yet), but it is quite mature.

As for the README.txt file it should be renamed to remove the extension - README.


#3

On Monday I will have a look at the draft extension. If it’s not part of BIDS yet, can I use it when uploading the dataset or I should still rely on .bidsignore?

I have now put .bidsignore file in the root folder with that syntax but the validator still consider the EEG data.

Finally, I renamed README without extension but it still fails to recognise it…


#4

Since the EEG extension is still work in progress you would need to use .bidsignore.

Are you getting the same results with the standalone validator? http://incf.github.io/bids-validator/

If you could somehow share a minimal (say one subject) dataset with me I would be happy to have a look.


#5

To test this I just made a synthetic dataset with extra EEG folder with a single test file in it.

krzys@spectre MINGW64 ~/OneDrive/data/ds256
$ ls sub-CTS201/EEG
test

Without the .bidsignore file the validator gives me the expected error. After adding

krzys@spectre MINGW64 ~/OneDrive/data/ds256
$ cat .bidsignore
/sub-*/EEG/

the error goes away as expected.


#6

Hi Chris,

I have tried again now, without changing anything since last time, and the EEG data do not give an error anymore. Neither does the README file. It seems to work in this respect, many thanks.


#7

Hi Chris

I am not sure why but now it doesn’t seem to read neither the README file nor the .bidsignore.

I will send you one subject if that’s fine with you


#8

Is it just OpenNeuro or are you getting the same results with the standalone validator? http://incf.github.io/bids-validator/


#9

I tried both openNeuro and the standalone validator. Same results


#10

I got your data. There are couple of issues:

  1. The readme file should be named README (no file extension), but in your case is named README.txt. Maybe the the file explorer your are using does not show extensions and that’s why you thought the file was renamed?

  2. The .bidsignore files should consist of only one line:
    /sub-*/EEG

I think you confused the syntax with the config file which is something different.


#11

Thank you all sorted now, I am uploading the dataset as we speak. Finally :slight_smile: